[12.04] Nautilus Samba workgroup/domain lowercase

NoOp glgxg at sbcglobal.net
Thu Dec 27 04:47:24 UTC 2012

Ran into a new (to me) issue connecting to a file share on a Windows 7
machine today. I couldn't connect to the machine via Nautilus; tried
existing (Win7) account, domain & password, tried connecting using
another account, domain & password, checked & double checked the share
folder, check my /etc/samba/smb.cnf, started restarted smbd & nmbd,
etc., etc.  I tried just about everything that I could think of... no
luck. Finally, I changed the workgroup/domain to all uppercase & it

The issue is that the Win7 machine requires that the workgroup/domain
name be in uppercase, Ubuntu's Samba login prompt *always* prompts in
lowercase. Example:

Nautilus|Go|Network|Windows Network|MSHOME (workgroup/domain)|<share
you now get prompted for:
Username: <autofills with you ubuntu username - lowercase>
Domain: mshome <autofills with the workgroup/domain name you've set up -
Password: <blank>

Even if the /etc/samba/smb.conf workgroup parameter is set to uppercase:
'workgroup = MSHOME' the
Nautilus 'Domain:' *always* autofills lowercase 'mshome'. This causes
the Win7 share authentication to fail. Note: the workgroup/domain on
Win7 is uppercase and (as far as I know) cannot be changed to lowercase.

If I overwrite the 'Domain: mshome' with 'Domain: MSHOME' the login
connection works perfectly.

Anyone run across this?
Anyone know where the Nautilus Samba prompt code originates from?

I've looked through launchpad & the closest that I can find is an old
bug regarding sharenames being converted to lowercase. But nothing
regarding the domain name autofill changing to lowercase. I'll file a
new bug report, but would first like to know if anyone else has
experienced the same problem & have a possible workaround.

More information about the ubuntu-users mailing list