openssl depends on libssl1.0.0
nileshkumar.pitroda at finicity.com
Fri Aug 24 14:59:31 UTC 2012
On Fri, Aug 24, 2012 at 4:49 PM, NileshKumar Pitroda <
nileshkumar.pitroda at finicity.com> wrote:
> On Ubuntu 10.04 server, we need to upgrade openssl version to 1.0.1-4, to
> resolve vulnerability OpenSSL FIPS Mode Diffie-Hellman Key Exchange
> Predictable Secret MiTM Weakness.
> While upgrade we are getting the following dependency error message.
> dpkg -i openssl_1.0.1-4ubuntu5.5_
> (Reading database ... 260992 files and directories currently installed.)
> Preparing to replace openssl 0.9.8k-7ubuntu8.5 (using
> openssl_1.0.1-4ubuntu5.5_amd64.deb) ...
> Unpacking replacement openssl ...
> dpkg: dependency problems prevent configuration of openssl:
> openssl depends on libc6 (>= 2.15); however:
> Version of libc6 on system is 2.11.1-0ubuntu7.10.
> openssl depends on libssl1.0.0 (>= 1.0.1); however:
> Package libssl1.0.0 is not installed.
> dpkg: error processing openssl (--install):
> dependency problems - leaving unconfigured
> If we installed this openssl_1.0.1-4ubuntu5.5_amd64.deb package forcefully
> on the system, will is cause any further issues.
> Please help.
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the ubuntu-users