<br><div class="gmail_quote">On Fri, Aug 24, 2012 at 4:49 PM, NileshKumar Pitroda <span dir="ltr"><<a href="mailto:nileshkumar.pitroda@finicity.com" target="_blank">nileshkumar.pitroda@finicity.com</a>></span> wrote:<br>

<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Team,<br><br>On Ubuntu 10.04 server, we need to upgrade openssl version 
to 1.0.1-4, to resolve vulnerability  OpenSSL FIPS Mode Diffie-Hellman 
Key Exchange Predictable Secret MiTM Weakness.<br><br>While upgrade we are getting the following dependency error message.<span style="font-weight:normal;font-size:12px"><br>
<br></span><br>dpkg -i  openssl_1.0.1-4ubuntu5.5_<div>amd64.deb<br>(Reading database ... 260992 files and directories currently installed.)<br>Preparing to replace openssl 0.9.8k-7ubuntu8.5 (using openssl_1.0.1-4ubuntu5.5_amd64.deb) ...<br>



Unpacking replacement openssl ...<br>dpkg: dependency problems prevent configuration of openssl:<br> openssl depends on libc6 (>= 2.15); however:<br>  Version of libc6 on system is 2.11.1-0ubuntu7.10.<br> openssl depends on libssl1.0.0 (>= 1.0.1); however:<br>



  Package libssl1.0.0 is not installed.<br>dpkg: error processing openssl (--install):<br> dependency problems - leaving unconfigured<br><br><br>If we installed this openssl_1.0.1-4ubuntu5.5_amd64.deb package forcefully on the system, will is cause any further issues.<br>



<br>Please help.<br><br>Thanks<br>Nilesh</div>
</blockquote></div><br>