gnome-applet-volume-control is a huge usability regression

Colin Law clanlaw at
Sun Aug 19 11:23:34 UTC 2012

On 19 August 2012 12:00, Gene Heskett <gheskett at> wrote:
> On Sunday 19 August 2012 06:39:59 Colin Law did opine:
>> On 19 August 2012 11:02, Gene Heskett <gheskett at> wrote:
>> > Greetings all;
>> >
>> > Ubuntu-10.04.4 LTS
>> >
>> > Some so-called update in the last 2 weeks has moved the system volume
>> > control from my keyboard, to a teeny little icon in the notifier
>> > applet.
>> >
>> > Generally when I need to get to it because the fscking commercial in
>> > front of a news story is 40 db louder than the previous watched
>> > stories audio track was, trying not to wake the missus sleeping 4
>> > rooms away, but because the mouse pointer has been blanked, you can't
>> > find the SOB without issuing a click someplace to unblank it just so
>> > you can move the pointer to this microscopic icon in the upper right
>> > corner of the screen, then roll the wheel to adjust the volume.  That
>> > works, but the extra click needed to unblank the mouse (why does it
>> > not unblank just by moving it?)

Is it a wireless mouse?  I suspect that is to do with the mouse itself
and nothing to do with ubuntu.  It is switching the light off in order
to save power.  Since the light is off it cannot tell when you move it
(obviously), hence the need to click.

>> > is occasionally miss interpreted
>> > causing unwanted side effects, and it takes several seconds of waving
>> > the ^%$ mouse around to find it in the screen clutter and do it.
>> >
>> > My keyboard has volume up/down/mute functions buttons which DID work
>> > very well and instantly, and could be used in a second or less for
>> > this until some "genius" thought it could be better done with an
>> > icon.  Quotes intended to be satire of course because left to my
>> > natural instincts, genius isn't the proper descriptive word.
>> I think you may be jumping to the false assumption that the disabling
>> of the keyboard function keys has been done on purpose.  I think it
>> more likely to be accidental.  Rather than ranting about supposed
>> intentional changes apparently intended to annoy you personally
> I'd bet a bottle of your favorite suds I am not the only one disappointed
> by such a usability regression.

I am sure you are not the only one disappointed, assuming that others
have also got the problem.  That does not mean the disabling of the
keyboard keys is intentional.

I can't comment on whether the volume applet in the panel has changed
as I don't use 10.04.  Anyone else help on this issue?

>> I
>> think a better approach would be to ask for help in analysing why the
>> function keys do not work.  In order to help with this the first
>> information required is full details of the make and model of the
>> machine.  I presume you have already searched launchpad in case it has
>> already been reported.
> No, I wanted to make sure I pointed out (but didn't really) that this
> little icon showed up at the last reboot about 2 weeks ago, it wasn't there
> before that I can recall, and my keyboard controls worked.  That is a logic
> connection even I can make.  The obvious conclusion is that this icon has
> intercepted those 3 keyboard events.

No, I don't think that is obvious at all.  Possible but not obvious.
If it were intercepting them then the fact that it is not acting on
them is still a bug.

>  Launchpad URL?

I don't understand, are you asking me to look up the url of launchpad for you?
I have had a quick look and can't see anything obvious.

>> Have you touched the BIOS settings recently?
> Not in over a year.

Worth asking the question.

>  Its an AMD 4 core phenom 9550, on an ASUS M2N-SLI
> Deluxe board, 4GB of ram, sound is an audigy2 value, aka real 24 bit
> hardware.  Motherboard sound is disabled, has been for years.
>> Have you tried a re-boot?
> 2 weeks ago.  Rebooting here is about a 10 to 20 minute project due to the
> custom scripts that handle my email needing to be hand started in sequence.
> I could automate that if I could figure out where to put a script that
> would be equal to rc.local, but which was executed once X was up and
> running.

Was that re-boot after you noticed that the volume keys were not
working?  If not then I think you have to do a re-boot before doing
anything else.
You could still put it in a single script and run that manually once X
is up,   Or call it from Startup Applications and then it will run
after logon if that is what you mean.

> This isn't supposed to be windows where multiple daily reboots need to be
> done is it?  ;-)



More information about the ubuntu-users mailing list