gnome-applet-volume-control is a huge usability regression

Gene Heskett gheskett at
Sun Aug 19 11:00:14 UTC 2012

On Sunday 19 August 2012 06:39:59 Colin Law did opine:

> On 19 August 2012 11:02, Gene Heskett <gheskett at> wrote:
> > Greetings all;
> > 
> > Ubuntu-10.04.4 LTS
> > 
> > Some so-called update in the last 2 weeks has moved the system volume
> > control from my keyboard, to a teeny little icon in the notifier
> > applet.
> > 
> > Generally when I need to get to it because the fscking commercial in
> > front of a news story is 40 db louder than the previous watched
> > stories audio track was, trying not to wake the missus sleeping 4
> > rooms away, but because the mouse pointer has been blanked, you can't
> > find the SOB without issuing a click someplace to unblank it just so
> > you can move the pointer to this microscopic icon in the upper right
> > corner of the screen, then roll the wheel to adjust the volume.  That
> > works, but the extra click needed to unblank the mouse (why does it
> > not unblank just by moving it?) is occasionally miss interpreted
> > causing unwanted side effects, and it takes several seconds of waving
> > the ^%$ mouse around to find it in the screen clutter and do it.
> > 
> > My keyboard has volume up/down/mute functions buttons which DID work
> > very well and instantly, and could be used in a second or less for
> > this until some "genius" thought it could be better done with an
> > icon.  Quotes intended to be satire of course because left to my
> > natural instincts, genius isn't the proper descriptive word.
> I think you may be jumping to the false assumption that the disabling
> of the keyboard function keys has been done on purpose.  I think it
> more likely to be accidental.  Rather than ranting about supposed
> intentional changes apparently intended to annoy you personally

I'd bet a bottle of your favorite suds I am not the only one disappointed 
by such a usability regression.

> I
> think a better approach would be to ask for help in analysing why the
> function keys do not work.  In order to help with this the first
> information required is full details of the make and model of the
> machine.  I presume you have already searched launchpad in case it has
> already been reported.

No, I wanted to make sure I pointed out (but didn't really) that this 
little icon showed up at the last reboot about 2 weeks ago, it wasn't there 
before that I can recall, and my keyboard controls worked.  That is a logic 
connection even I can make.  The obvious conclusion is that this icon has 
intercepted those 3 keyboard events.  Launchpad URL?

> Have you touched the BIOS settings recently?

Not in over a year.  Its an AMD 4 core phenom 9550, on an ASUS M2N-SLI 
Deluxe board, 4GB of ram, sound is an audigy2 value, aka real 24 bit 
hardware.  Motherboard sound is disabled, has been for years.
> Have you tried a re-boot?

2 weeks ago.  Rebooting here is about a 10 to 20 minute project due to the 
custom scripts that handle my email needing to be hand started in sequence.  
I could automate that if I could figure out where to put a script that 
would be equal to rc.local, but which was executed once X was up and 

This isn't supposed to be windows where multiple daily reboots need to be 
done is it?  ;-)
> Colin

Thanks Colin.

Cheers, Gene
"There are four boxes to be used in defense of liberty:
 soap, ballot, jury, and ammo. Please use in that order."
-Ed Howdershelt (Author)
My web page: <> is up!
There's enough money here to buy 5000 cans of Noodle-Roni!

More information about the ubuntu-users mailing list