Problems with repartitioning a HP Pavilion Laptop

Kaj Haulrich kaj.haulrich at
Fri Aug 17 19:02:11 UTC 2012

On 08/17/2012 08:03 PM, Bill Stanley wrote:
> Hi,
> I have installed Linux on many computers but this is the first time I
> had any problems.  The computer is a new HP Pavilion Model dV6 laptop, I
> assume the HD is ATA Hitachi HTS54505.  I used the Windows partitioning
> utility to resize the Windows partition so I would have some unused
> space (100 GB) where I could install Linux.  This went smoothly and
> Windows ran smoothly with the reduced partition size.  I used Windows
> about a month without any problems.
> Yesterday, I had some free time so I decided to install Xubuntu (12.04 -
> 64 bit) and all seemed to go smoothly.  The steps I followed were...
> I chose "something else" when prompted for the install type.
> I then set up the new partition table as
> sda1 -      1 MB - unknown  (I did nothing here)
> sda2 -    208 MB - ntfs     (I did nothing here)
> sda3 - 400000 MB - ntfs     (The resized Windows partition
>                               I did nothing here)
> The free space was 100000 MB.  I partitioned the free space as follows.
> (sda4 -  No sda4 ???)
> sda5 -   7998 MB -logical partition - swap area
> sda6 -  49999 MB -logical partition - Ext4  - mount as /
> sda7 -  42003 MB -logical partition - Ext4  - mount as /home
> boot loader (GRUB) at dev/sda
> I then clicked on "Install now".
> I got the location map and then a pop window saying that an error
> occurred.  It says...
> "             ERROR!
> Error informing the kernel about modifications to partition 4 - Device
> or resource busy.  This means Linux won't know about any changes made to
> /dev/sda4 until you reboot - so you shouldn't use it before rebooting"
> I thought this was insignificant since sda4 wasn't listed in the
> proposed partition scheme.  I chose "ignore".
> Then I got the same message about sda5, sda6, and sda7.  I knew
> something was amiss so I aborted the installation.
> The problem is that now I can't even boot into Windows because the
> installation attempted to install GRUB.  I was able to save any user
> data to a flash drive before trying the failed install.
> I thought that this might be a Ubuntu only problem so I tried installing
> Mint.  Same problem.  The vexing thing was that I didn't get much of a
> clue to what was happening. Since Ubuntu and Mint are Debian based, I
> tried a different flavor of Linux - Open Suse.  This time I did get an
> error message before partitioning even started.  It said that the
> partition scheme on the HD and the partitioning tool, parted, were
> incompatible.  (It might be nice if Ubuntu checked for partitioning
> problems before trying to repartition.) The error message that Open Suse
> gave was as follows...
> "The partitioning on disk dev/sda is not readable by the partitioning
> tool parted which is used to change the partition table.
> You can use the partitions on dev/sda as they are.  ..."
> I did all the BIOS diagnostics and no hardware problems were detected.
> That is the history of what has been done.  The laptop is unusable since
> I can't boot into Windows, luckily I had the foresight to get a Windows
> installation disks from HP.  The Windows installation disk says that a
> repair can't be done and I must do a full reinstall.  What can be done
> now?  I assume that I should try to install Linux first and then
> Windows.  Does anybody know about any new partitioning scheme that MS
> has come up with that would mess up Linux?  I assume that if I reinstall
> Windows as is, I will run into the same mess when I try to install Linux.
> Sorry for the long message but I thought it wise to give as much
> information as possible to answer any questions you might have.
> Bill Stanley
I ran into similar hiccups with my - also new - Pavillon, until I 
realized that it had this new thingy called UEFI rather than the good 
old BIOS. If yours suffer from the same malady, the solution is to use 
grub-efi during the install and tell it to install grub-efi on sda1 
(something like 100 MB).

Kaj Haulrich.
--- Sent from a 100% Microsoft-free computer---
--------- Running Linux Kubuntu 12.10 ---------

More information about the ubuntu-users mailing list