How to upgrade from java6 to java7 on 10.04?

Jim Byrnes jf_byrnes at
Fri Aug 17 15:22:02 UTC 2012

On 08/17/2012 09:51 AM, Jim Byrnes wrote:
> On 08/16/2012 10:21 PM, NoOp wrote:
>> On 08/16/2012 10:34 AM, Jim Byrnes wrote:
>>> Firefox popped up a warning yesterday that Java6 had security problems
>>> and should be upgraded to Java7. I googled upgrading to Java7 and found
>>> various answers ranging from giving step by step manual instructions to
>>> recommending using ppa/webup8.
>>> My concern is they all seemed to focus on installing Java7 but I didn't
>>> see anything about upgrading.  What happens to my Java6 installation?
>>> Just looking for a smooth, hassle free way to get secure java running
>>> again.
>>> Thanks,  Jim
>> I use:
>> Script (JRE only)
>> Only supports Oracle (Sun) Java 7 JRE (which covers the needs of 99 % of
>> all computer users). It pulls the packages from Oracle's website and
>> installs them, comparable to the way Adobe Flash Player is being
>> installed. Plus it adds a dedicated repository, from which you'll
>> receive updates automatically.
> This looks to be exactly what I need.  I was wondering about the sun
> java 6 I had installed but the website says the script will remove it.
>> Java 7 works fine with Firefox, but as a heads-up it does not with
>> SeaMonkey:
>> <>
>> [[linux] Sun Java jre1.7.0_04/_05 does not work in SeaMonkey]
> I have always liked Seamonkey but finally had to stop using it because
> some sites I use on a regular basis just would not work fully when I was
> using it.
>> You might consider just giving in and installing openjdk & icetea
>> instead.
> I use jEdit so that's not a good option for me.  There have been
> problems reported using them with jEdit and the devs only support it on
> the Sun version. (which I fully understand)
> Thanks,  Jim

OK I started the process using the Repository option.

I added deb debs all using Software Sources 
from the system menu, then tried to import the gpg key:

~$ sudo apt-key adv --keyserver --recv-keys 5CB26B26
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring 
--secret-keyring /etc/apt/secring.gpg --trustdb-name 
/etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring 
/etc/apt/trusted.gpg --keyserver --recv-keys 5CB26B26
gpg: requesting key 5CB26B26 from hkp server
gpg: keyserver timed out
gpg: keyserver receive failed: keyserver error

I've tried it a couple of times with the same result.  Does this look 
like a temporary problem that will clear up or something else?

Thanks,  Jim

More information about the ubuntu-users mailing list