update killed my sound AGAIN!!!

John Rose john.aaron.rose at gmail.com
Thu Apr 5 11:22:01 UTC 2012

I don't want to try a LiveCD as every time I modify/install a new kernel, I have
to recompile the Ethernet driver (to get internet connection back) due to there
being no module for the Atheros 1083 Ethernet Controller in i.e. one
that Ubuntu Lucid uses. I guess that sound problem could be caused by lack of a

Another possibility:
I have even tried most of Ubuntu's Community Sound Troubleshooting''s
instructions. Audio codec/mixer/device are all ALC887. Interestingly says to add
'options snd-hda-intel model=YOUR_MODEL' to /etc/modprobe.d/alsa-base.conf where
YOUR_MODEL is defined on:
However, there is no ALC887 (though there is ALC882/883/885/888/889 & ALC880)
defined on that webpage. I seem to recall a similar issue on my old laptop on
which I originally (5 years ago) installed Ubuntu LTS-prior-to-Lucid (I've
forgotten the version name) and that was solved somehow: I checked for 'options
snd-hda-intel model=YOUR_MODEL' in /etc/modprobe.d/alsa-base.conf but nothing
looking like that. Looking at http://www.kernel.org, I don't think that they
want email about such issues. Any ideas about following this up?

More information about the ubuntu-users mailing list