vpn works once then need reboot to work again

Wes James comptekki at gmail.com
Thu Sep 29 16:06:52 UTC 2011

I've installed this vpn ppa package:


It works fine on the first try, but then if I disconnect and then try
to connect again it fails.

Sometimes if I use the Inidicator to stop the network then start it up
again it works, but rarely.

Once I tried dhclient -r and then dhclient again and it would work,
but I haven't gotten that procedure to work again.

I've also tried running this script - it worked once - but then not again.

sudo /etc/init.d/l2tp-ipsec-vpn-daemon stop
sudo /etc/init.d/xl2tpd stop
sudo /etc/init.d/ipsec stop
sudo /etc/init.d/l2tp-ipsec-vpn-daemon start

I've tried:

sudo ifdown eth0
sudo ifup eth0

still no go for second vpn connection.

The only way to get the vpn to connect again is to reboot.

Any ideas on how to get this to be more reliable on consecutive vpn
connection attempts?

This is on 11.04 Natty Narwhal - latest updates, Gnome desktop, dell
optiplex gx 980



More information about the ubuntu-users mailing list