Unable to install any package in ubuntu (10.04)

Avi Greenbury lists at avi.co
Sun Jul 24 16:43:23 UTC 2011

Amrit Pal Pathak wrote:

> > But do you know *why* it worked Amrit?"
>     No .
>      I just used it.Can you please explain me ?

If you run 

man apt-get

You will get the manual for the 'apt-get' command. Most commands have
one so, in general, 'man somecommand' will get you some documentation
for the command. It probably wont immediately tell you what to do, but
you should find that by scrolling through it (or searching - hit '/'
then type a search term and hit enter) you'll get a good idea of what
it can do.

From man apt-get:

           clean clears out the local repository of retrieved package
       files. It removes everything but the lock file from
       and /var/cache/apt/archives/partial/. When APT is used as a
       dselect(1) method, clean is run automatically. Those who do not
       use dselect will likely want to run apt-get clean from time to
       time to free up disk space.

The reason this fixed it is because the previous errors were (somewhat
cryptically) describing a problem reading the files in the cache.
Removing them forces new, non-corrupt, ones to be downloaded.


More information about the ubuntu-users mailing list