Unable to install any package in ubuntu (10.04)

Amrit Pal Pathak amritpalpathak1 at gmail.com
Mon Jul 25 04:20:18 UTC 2011


On Sun, Jul 24, 2011 at 10:13 PM, Avi Greenbury <lists at avi.co> wrote:

> Amrit Pal Pathak wrote:
>
> > > But do you know *why* it worked Amrit?"
> >
> >     No .
> >      I just used it.Can you please explain me ?
> >
>
> If you run
>
> man apt-get
>
> You will get the manual for the 'apt-get' command. Most commands have
> one so, in general, 'man somecommand' will get you some documentation
> for the command. It probably wont immediately tell you what to do, but
> you should find that by scrolling through it (or searching - hit '/'
> then type a search term and hit enter) you'll get a good idea of what
> it can do.
>
> From man apt-get:
>
>       clean
>           clean clears out the local repository of retrieved package
>       files. It removes everything but the lock file from
>           /var/cache/apt/archives/
>       and /var/cache/apt/archives/partial/. When APT is used as a
>       dselect(1) method, clean is run automatically. Those who do not
>       use dselect will likely want to run apt-get clean from time to
>       time to free up disk space.
>
> The reason this fixed it is because the previous errors were (somewhat
> cryptically) describing a problem reading the files in the cache.
> Removing them forces new, non-corrupt, ones to be downloaded.
>
> Ok .Thank you sir.Next time i will use man command to read the
> documentation of the every command which i  am going to use.
>
> Thank you colin too.
>
> amritpalpathak.blogspot.com
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20110725/0ceb9e02/attachment.html>


More information about the ubuntu-users mailing list