Sound server & mic problem on 10.04

TopBot . topbot5 at
Fri Jul 22 07:41:40 UTC 2011

On Fri, Jul 22, 2011 at 10:16 AM, Ric Moore <wayward4now at> wrote:

> On Fri, 2011-07-22 at 03:22 +0500, TopBot . wrote:
> >
> >
> > On Fri, Jul 22, 2011 at 1:21 AM, Ric Moore <wayward4now at>
> > wrote:
> >         On Thu, 2011-07-21 at 14:11 +0100, Alan Pope wrote:
> >         > On 21 July 2011 13:57, TopBot . <topbot5 at>
> >         wrote:
> >         > > I just installed backtrack 5 (kde version - based on
> >         Ubuntu 10.04 LTS)  for
> >         > > some testing purposes, but its giving me problems as an
> >         operating system.
> >         > >
> >         >
> >         > Whilst Backtrack is derived from Ubuntu, it isn't Ubuntu.
> >         You might
> >         > get better support from a backtrack specific list or forum.
> >
> >
> >         Install 10.4 Ubuntu, then install the KDE packages after.
> >         Sound works.
> >         Kubuntu 10.4 hosed sound (pulse) for me as it relies on some
> >         other
> >         scheme that bombed. Ric
> >
> >
> > In my case the KDE is already installed (like kubuntu), there's no
> > gnome. So is there anyway to fix it from here (and continue to use
> > KDE) ? It seems like its not a backtrack specific problem. More of a
> > trouble from KDE.
> The last post on the Kubuntu list, before I bailed, was that they would
> fix sound in 10.10. My beef was that the LTS version needed fixing. It
> fell on deaf ears I fear. So, I clean installed Ubuntu 10.4, mostly out
> of meanness, tested sound with Gnome, and found it worked flawlessly.
> Then I installed KDE on top, sound continues to work to this day. Other
> than that, that's all I can say. Well, I COULD add that after doing
> this, I had to install the pavucontrol package... then crank up
> alsamixer to adjust things, then fired up pavucontrol to set up 5.1
> sound and keep it running to set individual applications to specific
> sound hardware. Skype would be set to use my USB headphones. Every time
> I run it, it switches to the headphones. Nifty... that is what pulse
> does for me. Running Xine, it switches automatically to 5.1 audio,
> unless it's late and I want to use the headphones to not bother others.
> Click and it's switched. Way cool... :) Ric

Yes, ubuntu as a genome install has always been really good. Simply offers
no problems what so ever the case. But I don't know why, when so much
development is being done in kde, the kde backend is not being given as much
importance. For instance sound codecs and other required packages are not
automatically searched on execution of requiring files.

My system falls back to HDA Intel (ALC883 Analog) from digital everytime i
start xserver (All sounds are working fine on dual boot windows & used to
work completely fine on all versions of ubuntu and all previous kubuntu
versions). So i think I have to replace some package, don't know which one
is causing the problem. By setting SMplayer's audio output device to alsa
(from alsa (0.0 HD)) I've atleast got it to work along with PCM (ie browser
based sounds from flash can now run along with the SMplayer). But still when
I run rhythmbox while SMplayer is running it says audiosink is missing
(while it works fine when it is playing alone and I cant find audio sink
through synaptic or the default settings menu). Also notifications also
don't give sounds when any other program is using the sound card. The same
sound server problem.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list