Need Help

Goh Lip g.lip at
Wed Aug 10 12:23:35 UTC 2011

On 08/10/2011 07:16 PM, Emmanuel Natalis wrote:

 > Yes am using server version so no  desktop installed. When booting the
 > machine, it was reaching in the stage where you can select normal
 > booting or recovery mode. I was able to login using the recovery mode
 > but after skipping some of the stages. When you leave it to boot in the
 > normal way, it becomes black and it just stays that way. I have tried to
 > uncomment the line which starts with GRUB_GFXMODE in /etc/default/grub
 > (When am in recovery mode) and run the command update-grub. I tried to
 > boot again but this time I cannot even see the boot grub options i.e
 > normal boot, recovery mod - It just becomes black.  Should this line
 > gfxmode="640x480" be added in the grub file i.e /etc/default/grub? But I
 > dont know how can I go to the recovery mode again as i dont see again
 > the boot options.

If you do this way, you need to "update-grub" to keep this option 
'alive', otherwise it is not applied. You can manually edit at the grub 
menu to temporarily effect this.

On 08/10/2011 07:33 PM, Emmanuel Natalis wrote:

 > Another thing which I have accidentally noticed, when I boot my machine
 > without plugging a monitor, am able to see the boot options. Hitting
 > enter on the first option - normal booting, a screen ending with words
 > /*initramfs*/ appears.

Okay, your first monitor is not 'booting up'. The method above (gfxmode) 
will probably show up the "/*initramfs*/" too. So you do have a more 
serious problem on top of your first monitor as well. It is not finding 
your initrd.img or your initrd.img is not at the first sector of the 

It's not good and you may need to reinstall, but you can try this first 
at the recovery mode...
sudo update-initramfs -u

Good luck _ Goh Lip

More information about the ubuntu-users mailing list