ssh_config file errors

MirJafar Ali mirjafarali at gmail.com
Thu Nov 4 23:50:03 GMT 2010


On Thu, Nov 4, 2010 at 6:37 PM, MirJafar Ali <mirjafarali at gmail.com> wrote:

>
>
> On Thu, Nov 4, 2010 at 5:32 PM, Jordon Bedwell <jordon at envygeeks.com>wrote:
>
>> On 11/04/2010 05:16 PM, MirJafar Ali wrote:
>> > Can someone send me the new copy which I can try or tell the solution.
>>
>> >
>> >
>> > /etc/ssh/ssh_config: line 11: Bad configuration option: HostKey
>> > /etc/ssh/ssh_config: line 12: Bad configuration option: HostKey
>> > /etc/ssh/ssh_config: line 14: Bad configuration option:
>> > UsePrivilegeSeparation
>> > /etc/ssh/ssh_config: line 17: Bad configuration option:
>> > KeyRegenerationInterval
>> > /etc/ssh/ssh_config: line 18: Bad configuration option: ServerKeyBits
>> > /etc/ssh/ssh_config: line 21: Bad configuration option: SyslogFacility
>> > /etc/ssh/ssh_config: line 25: Bad configuration option: LoginGraceTime
>> > /etc/ssh/ssh_config: line 26: Bad configuration option: PermitRootLogin
>> > /etc/ssh/ssh_config: line 27: Bad configuration option: StrictModes
>> > /etc/ssh/ssh_config: line 34: Bad configuration option: IgnoreRhosts
>> > /etc/ssh/ssh_config: line 43: Bad configuration option:
>> PermitEmptyPasswords
>> > /etc/ssh/ssh_config: line 62: Bad configuration option: X11Forwarding
>> > /etc/ssh/ssh_config: line 63: Bad configuration option: X11DisplayOffset
>> > /etc/ssh/ssh_config: line 64: Bad configuration option: PrintMotd
>> > /etc/ssh/ssh_config: line 65: Bad configuration option: PrintLastLog
>> > /etc/ssh/ssh_config: line 73: Bad configuration option: AcceptEnv
>> > /etc/ssh/ssh_config: line 75: Bad configuration option: Subsystem
>> > /etc/ssh/ssh_config: line 86: Bad configuration option: UsePAM
>> > /etc/ssh/ssh_config: terminating, 18 bad configuration options
>>
>> Those options are meant to go into sshd_config
>>
>> Try this command:
>> mv /etc/ssh/ssh_config /etc/ssh/sshd_config
>>
>> Then replace your ssh_config with a basic ssh_config:
>> Host *
>>    ForwardAgent no
>>    ForwardX11 no
>>    ForwardX11Trusted no
>>    RhostsRSAAuthentication no
>>    RSAAuthentication yes
>>    PasswordAuthentication yes
>>    HostbasedAuthentication no
>>    GSSAPIAuthentication no
>>    GSSAPIDelegateCredentials no
>>    GSSAPIKeyExchange no
>>    GSSAPITrustDNS no
>>    BatchMode no
>>    CheckHostIP yes
>>    AddressFamily any
>>    ConnectTimeout 0
>>    StrictHostKeyChecking yes
>>    IdentityFile ~/.ssh/identity
>>    IdentityFile ~/.ssh/id_rsa
>>    IdentityFile ~/.ssh/id_dsa
>>    Port 22
>>    Protocol 2
>>    Cipher aes256-ctr
>>    Ciphers
>> aes128-ctr,aes192-ctr,aes256-ctr,arcfour256,arcfour128,aes128-cbc,3des-cbc
>>    MACs hmac-sha1,umac-64 at openssh.com,hmac-ripemd160
>>    EscapeChar ~
>>    Tunnel no
>>    TunnelDevice any:any
>>    PermitLocalCommand no
>>    VisualHostKey no
>>    SendEnv LANG LC_*
>>    HashKnownHosts yes
>>    GSSAPIAuthentication no
>>    GSSAPIDelegateCredentials no
>>
>> --
>> ubuntu-users mailing list
>> ubuntu-users at lists.ubuntu.com
>> Modify settings or unsubscribe at:
>> https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
>>
>
>
> Hello,
>
> Thanks, it worked but has some problem with VNC:
>
> vncviewer: ConnectToTcpAddr: connect: Connection refused
> Unable to connect to VNC server
>
> Initally I was able to use VNC, so what parameters I must change.
>
> Thanks.
> csv
>
>

I restared VNC server and it worked.

Thanks for your help.

Mir
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-users/attachments/20101104/13e1da4b/attachment.htm 


More information about the ubuntu-users mailing list