Nvidia graphics trouble

NoOp glgxg at sbcglobal.net
Mon Nov 1 21:52:24 UTC 2010

On 10/21/2010 01:25 PM, Carsten Agger wrote:
> I'm trying to get a friend's computer to work with Ubuntu 10.10.
> Everything works fine, except the graphics card, an Nvidia GEForce 9800 GT.
> After a default installation, the screen blanks after booting, meaning 
> the monitor suddenly says "No input". This is probably due to the 
> failure of the free  "nouveau" nvidia driver.
> In order to even boot the computer, it's necessary to remove the boot 
> parameters "quiet splash" and replace them with "nomodeset". This, 
> however, disables 3D acceleration.
> Installing the proprietary Nvidia driver from System/Additional drivers 
> produces *exactly* the same result - a blank screen, no input received 
> by the monitor.
> We also tried downloading the newest driver from the Nvidia web site - 
> this made the screen blink while trying to launch X, after which it 
> bailed out to terminal login.
> Does anyone know how to make 3D acceleration work with this card? 
> Apparently it worked in 8.10 and 9.04 but has been broken in 10.04 and 
> 10.10 (don't know about 9.10). I was unable to find any help on the 
> wiki, alas.



Try x-swat:

$ sudo add-apt-repository ppa:ubuntu-x-swat/x-updates

More information about the ubuntu-users mailing list