emacs templates + header

spam.me at gmx.info spam.me at gmx.info
Mon Jun 21 11:21:07 UTC 2010

On Monday 21 June 2010 13:13:23 Karl Larsen wrote:
> On 06/20/2010 09:16 AM, spam.me at gmx.info wrote:
> > Hello!
> > 
> > I use Ubuntu since 8.x and use Emacs always with the same ".emacs" and
> > just the packages from the corresponding repository.
> > 
> > With Lucid, I got a problem. Usually when I create a new file "new.c,
> > new.h" then a header with author, date etc. and include "new.h", resp.,
> > #ifndef etc. is created. But now, nothing is happed. New files are
> > empty. Thats bad also in case of Makefiles.
> > 
> > So I add (auto-insert-mode t) in my .emacs file and now I will be ask to
> > input something or not, but no header will be set.
> > 
> > How can I come back to the previous level?
> > 
> > Thanks for any help.
Hi Karl,

>          Hi. Did you update your 8.x to Lucid or did you load lucid from
> a cd?

New workstation --> new installation.
>      It sounds like you might be using your old .emacs on Lucid. You
> need to load emacs from the repository and it will make a new .emacs for
> the new software :-)

the .emacs is just the configuration file in my home directory ?! But I tried 
your hint, and deleted .emacs and .emacs.d to to get a basic .emacs. The 
problem is still the same
>      It sounds like you need to change your setup a bit based on the new
> emacs ;-)

yeah, I'm getting old, now I knows how it feels 
> 73 Karl

More information about the ubuntu-users mailing list