nfs mount fails in Ubuntu 10, but not with -v

Joseph Loo joseph.loo at
Thu Jun 10 03:27:25 UTC 2010

Stuart Reynolds wrote:
> I've tried:
>       (1)  mount    -t nfs remotehost:/remotedir localmountpoint -o owner,rw
>       (2)  mount -v -t nfs remotehost:/remotedir localmountpoint -o owner,rw
> (1) Used to work with Ubuntu 9 and now fails with Ubuntu 10
> (2.6.32-21-generic kernel) with the error:
>        mount.nfs: an incorrect mount option was specified
> Strangely, adding -v (verbose) in (2) makes the problem go away.
> This is currently a blocker for me because the fstab line:
>        remotehost:/remotedir localmountpoint nfs owner,rw   0 0
> causes the same error (I don't believe I can specify verbose in fstab).
> Is this a bug in mount or are my options really incorrect?
> Thanks,
> - Stu
I see the same problem with autofs. my problem seems to me the autofs
daemon does not start up quick enough. if I do a manual start of autfs
it will work okay. if I wait a while or login into an account that does
not use an automount, it works shortly after. i had checked /etc/rc5.d
and it is in there. I suspect your problem is the same, the mount
portion of the program is not starting up fast enough.


Joseph Loo
jloo at

More information about the ubuntu-users mailing list