How to "disable zero CD" in order to get my USB mobile internet dongle working? <SOLVED?>

Bas Roufs basroufs at
Mon Jun 7 12:08:59 UTC 2010

Hello Nils and Everybody Else!

This afternoon, I did another test with the mobile internet dongle.
Before the lunch, I shut down all the running apps and then the whole
system all together - than I took out the dongle.
After restarting the netbook, I first connected to the internet via
the "normal" wired connection. Than, I took out the LAN-connector and
I inserted the dongle. Within about one minute, the mobile internet
connection started working - it is still working now.

>> As I said: the connection started working after giving in the correct
>> phone number meant to access the dongle: *99#
>> > Did you check that the USB ID of your device is included in the
>> > hso.udev file? If it isn't, it can't work. You can see your USB ID
>> > with the command lsusb
Another weird detail is that the only hso.udev file I have found so,
is the one I installed from the ozerocd website.

>> The lsusb test delivers the following outcome with respect to the
>> dongle: Bus 001 Device 003: ID 12d1:14ac Huawei Technologies Co.,
>> Ltd.
> It would not have worked with the original ozerocdoff package because
> your device isn't listed in the hso.udev file - it is a different vendor
> ID. But anyway, you managed to make it work without this package, so
> this package isn't useful for you.
As I said above: I did not find any other hso.udev file beside the one
I mentioned above. And ideed - the ID I found via the lsusb test does
not appear in the hso.udev file I have.
>> > in a terminal. If the identification string isn't obvious, check
>> > the difference between the output when the dongle is connected and
>> > not connected to the USB port.
>> "Connected and not connected": do you mean in this context: mounted
>> or not mounted?
> No, not mounted / unmounted - I meant with the dongle inserted to the
> USB port or not inserted.

With the dongle inserted, one of the USB devices mentioned by the
lsusb test is this one:
Bus 001 Device 004: ID 12d1:14ac Huawei Technologies Co., Ltd

Without the dongle inserted, this Huaei ID vanishes when carrying out
again a lsusb test.

>> > And did you try to mount the zero cd and then eject it? If it works
>> > similar to a WLAN dongle I have, it would switch to the modem mode
>> > after the zero cd is ejected.
>> The weird thing is now, that my dongle seems to work even while it is
>> mounted as zero cd.
> I suppose, the zero cd wasn't a problem in the first place but the wrong
> phone number which you corrected now.

Respectfully yours,


More information about the ubuntu-users mailing list