How to "disable zero CD" in order to get my USB mobile internet dongle working? <SOLVED?>

Bas Roufs basroufs at
Mon Jun 7 10:47:41 UTC 2010

Hello Tony, Nils, Sinclair and Everybody Else

While I started writing this message, I "suddenly" managed to
establish the mobile internet connection. Correcting one of the
provider specific codes in Network Manager was enough to get the
connection via the dongle running. However, I would like to evaluate
now what I need to do or not to do in order to keep this connection
properly running. Below, I work out this question in more detail.

>> Wether I try KPPP, WVDIAL or KNetworkmanager: still the dongle is
>> being mounted as a CD Rom each time I insert him in it. Also each
>> restart together with the dongle ends up in this "zero CD"result. Does
>> anybody have a clue how to permanently reset the laptop in such a way
>> that the dongle will be automatically correctly recognised and dealt
>> with?

Apparently you are right Tony:although the dongle is being mounted as
a "zero CD", the internet connection is working now. However, I am
wondering whether is better or not to:
each time "unmount", "eject" or "release" it, or....
to change the settings in such a way that the dongle will not be
mounted any more as "zero CD"
Or is this simply not relevant?

>> OS: dual boot Kubuntu Lucid and Win7.
>> Dongle: HUAEI E1820.
>> Netbook/ laptop: Eee PC 1001HA, 250GB HD, 1GB RAM.
>> Test result: at the Windows partition, the dongle works
>> automatigically, at the Linux partition still not.

Provider: T-Mobile NL, . Other
provider-specific specifics:
Number (for accessing the dongle): *99#
APN: internet
Account Name: tmobile
Password: tmobile
Additionally, I also have given in the PIN and PUK codes.

In the mean time, I one time restarted the netbook in order to test
the connection. And yes: also after this restart, the mobile internet
connection seems to work properly.

> I have used my wife's USB mobile internet dongle (its a Huawei
> K3565) with no trouble at all. Yes, it does show up as a storage
> device, because it has a micro SD storage card in it, mounted at
> /media/VMC LITE  But that has nothing to do with its
> internet function in Ubuntu.  I think it has Windows software on it.

My dongle is being mounted as follows: /media/T-Mobile/
It also has Windows software.

> The internet function is enabled through the Network applet.  Under
> Lucid (Ubuntu, not Kubuntu) it just tells me in the list of possible
> connections that there is a 'New Mobile Broadband (GSM)
> connection...'  I click on that and it takes me to a dialog where I select
> Country (Britain(UK) in this list - why they cannot standardise on
> United Kingdom, I will never know), then my Provider (Vodaphone)
> then my (wife's) Billing Plan (TopUp and Go).  Once I confirm all that
> - it works!
> So, what doesn't work for you?

As I said: the connection started working after giving in the correct
phone number meant to access the dongle: *99#
After a first restart, the connection continues properly working.
However, I have adapted some settings the past few days - but I am not
sure which of those adaptations were relevant. I would like to
evaluate which settings are essential to ensure a properly working
mobile internet connection.

> ....(snip) BASIC INFO ... details of your mobile provider.
See above.

> Did you check that the USB ID of your device is included in the hso.udev
> file? If it isn't, it can't work. You can see your USB ID with the command lsusb
The lsusb test delivers the following outcome with respect to the dongle:
Bus 001 Device 003: ID 12d1:14ac Huawei Technologies Co., Ltd.

> in a terminal. If the identification string isn't obvious, check the
> difference between the output when the dongle is connected and not
> connected to the USB port.
"Connected and not connected": do you mean in this context: mounted or
not mounted?

> And did you try to mount the zero cd and then eject it? If it works
> similar to a WLAN dongle I have, it would switch to the modem mode after
> the zero cd is ejected.

The weird thing is now, that my dongle seems to work even while it is
mounted as zero cd.
Respectfully yours,


More information about the ubuntu-users mailing list