Hi! I'm new to UBUNTU!

Calcpage calcpage at aol.com
Tue Jun 1 17:52:26 UTC 2010

On Jun 1, 2010, at 10:20 AM, Maurice McCarthy <manselton at gmail.com>  

>> So, I tried "sudo aptitude update" and got thru 12 gets without a
>> hitch.  Every get after that had an error like "Sub-process /bin/ 
>> bzip2
>> returned an error code (2)".   36 gets were atempted but the last 24
>> had that bzip2 error.  What can I do about this?
>> TIA,
>> A. Jorge Garcia
>> http://shadowfaxrant.blogspot.com
> Jorge
> In the man page for bzip2
>       Return values: 0 for a normal exit, 1 for environmental  
> problems  (file
>       not found, invalid flags, I/O errors, &c), 2 to indicate a  
> corrupt com‐
>       pressed file, 3 for an  internal  consistency  error  (eg,   
> bug)  which
>       caused bzip2 to panic.
> So error code 2 is a corrupt compressed file (i.e. the downloaded .deb
> file) which suggests something wrong with transmission or reception or
> hardware rather than the operating system. This may not be Ubuntu
> related. I'm afraid I'm getting out of my depth but have a look at log
> files in /var/log such as the apt folder or aptitude file to see if
> there are any clues.
> You might try
> aptitude reinstall bzip2
> just to rule that out but it is not likely to change anything.
> Best
> Maurice
> -- 
> ubuntu-users mailing list
> ubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

I did everything you suggested a still no joy.  The logs just  
contained time stamps for everytime I started an update all of which  

I don't know how bzip2 is corrupted as this a fresh install from a  
live Ununtu 10.04 CD...

More information about the ubuntu-users mailing list