ubuntu touchpad control

NoOp glgxg at sbcglobal.net
Wed Jul 21 01:14:44 UTC 2010

On 07/20/2010 05:11 PM, Pete Vander Giessen wrote:
>   On 07/20/2010 03:39 PM, Ronald B Cadby wrote:
>> I have a dual boot Win-7, lucid 10.4 on a new Asus laptop.
>> ...
>> My biggest aggravation at the  moment is when I inadvertently touch or
>> brush by the touchpad with the heel of my hand. All sorts of bad things
>> happen like the cursor jumping away or (sometimes unknowingly) pasting
>> clipboard content into whatever file I have open.
> Hi Ron,
> Try going into System -> Preferences -> Mouse.  On the touchpad tab, 
> uncheck "Enable mouse clicks with touchpad".
> If that doesn't work, or if you've already tried it, you might be able 
> to disable the touchpad in your computer's BIOS settings.

I had a similar problem with my HP G60-530US; the button to turn off the
touchpad simply didn't work. Somewhere along the line an update
corrected that (no clue which one), and now it works after I log in. Not
sure if it makes any difference, but my
System|Preferences|Mouse|Touchpad - all are unclicked with the exception
of 'Edge scrolling'. If I enable the touchpad via the on/off button I
can still use the touchpad (this is a good thing IMO as I don't always
use the mouse).

However, to disable permanently (courtesy of a recent thread over on

> Just create a file  
>      /etc/modprobe.d/blacklist-touchpad.conf
> with the single line
> blacklist	psmouse

$ gksu gedit /etc/modprobe.d/blacklist-touchpad.conf
add: blacklist	psmouse
save. Reboot.

If you need to turn it back on comment out 'blacklist psmouse' in
/etc/modprobe.d/blacklist-touchpad.conf. Leave the file in case you need
it later:

$ gksu gedit /etc/modprobe.d/blacklist-touchpad.conf
blacklist	psmouse
# blacklist	psmouse
save. Reboot.
Or if you need to do so temporarily while still logged in:

$ sudo modprobe -i psmouse
and to turn it back off while still logged in:
$ sudo modprobe -r psmouse

Those are a little drastic, but will work (I've tested both). Recommend
that the OP try to figure out why his keys for turning the touchpad
on/off are not working to begin with.

More information about the ubuntu-users mailing list