no AppleTalk?

Pete Gontier pete at
Mon Jul 12 19:21:56 UTC 2010

Yep; I too googled around and experimented with editing the configuration
files and restarting and that sort of thing.

I completely understand about AppleTalk being so old that hardly anybody
tests with it. Heck; even Mac OS has abandoned support for AppleTalk at this
point. Most people would have worn out one of these printers and replaced it
by now, but I use it only once every few months, so its page count is very
low for its age.

The fact that I can mount my Ubuntu home on Mac OS proves only that AFP over
IP works; it doesn't prove that DDP works. I haven't yet tried to configure
printing. I'm trying to get any evidence that DDP works at all before trying
to make any higher-level protocol work. So far, every indication I get is
that DDP doesn't work, so if I were to try to make printing work I'd just be
driving myself crazy with another layer of error abstraction. :-)

Pete Gontier <>

On Mon, Jul 12, 2010 at 11:03 AM, Hakan Koseoglu <hakan at> wrote:

> Hi Pete,
> On 12/07/10 18:34, Pete Gontier wrote:
> > Further, you seem to suggest that AppleTalk is indeed in the Ubuntu
> > kernel, and there must be some other reason all the netatalk userland
> > programs I've tried say:
> Your statement about Ubuntu not having the kernel modules is not correct
> but this doesn't mean that configuration for userland is supplied ready
> for PnP configuration :)
> >     atp_open: Cannot assign requested address
> >
> >
> > (Even though I've made no explicit attempt to assign any address.) What
> > else can I try to diagnose this? (I've already tried making the
> > interface netatalk is supposed to use explicit.)
> I am not very familiar with appletalk but as I understand it still
> requires an address to be mapped to it so that hosts can talk to each
> other. After googling for a couple of minutes I found a couple of
> examples where various netatalk configuration files are manipulated but
> I'm not sure if these are relevant to your situation.
> My ipddp0 interface appeared with no address, my netatalk daemon was up
> and I left it there and purged it away. I don't have any appletalk
> routers around to test anything with this protocol.
> Did you look into /etc/atalktd.conf and /etc/defaults/netatalk?
> I suppose it all boils down to the fact that there are so little amount
> of people with these ancient devices, not a lot of people bother testing
> them.
> In an earlier mail you mentioned that you managed to mount your Ubuntu
> home on your Mac via Appletalk so I guess most of the configuration works.
> One other thing I had noticed during browsing around was the CUPS
> appletalk back end, which might be the problem about printing and here's
> some more (probably out of date) documentation on that:
> --
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list