building and installing a new kernel makes my system unbootable

Robert P. J. Day rpjday at
Tue Jul 6 09:06:07 UTC 2010

On Tue, 6 Jul 2010, Colin Law wrote:

> On 6 July 2010 09:49, Robert P. J. Day <rpjday at> wrote:
> > On Mon, 5 Jul 2010, Chan Chung Hang Christopher wrote:
> >
> >> Robert P. J. Day wrote:
> >> >   some strange things happening here -- for the first time, after
> >> > i configured and built a new kernel, i ran "make deb-pkg" to turn
> >> > it into a .deb package file, then used "dpkg" to install that,
> >> > after which i still apparently had to run the appropriate
> >> > incantations of "update-initramfs" and "update-grub", then i
> >> > rebooted.
> >> >
> >> >   the boot process is clearly trying to boot the new kernel
> >> > (2.6.35-rc4+), only to fail with an error trying to mount the root
> >> > filesystem.  no problem, thinks i, i'll just reboot, drop into
> >> > GRUB and select the earlier, working kernel ... except that
> >> > nothing i do will get me to GRUB -- not SHIFT, ESC or TAB.  when i
> >> > installed my ner kernels manually, SHIFT always worked, but now, i
> >> > have no idea what's changed.
> >>
> >> sounds like stage1 not being able to load stage2
> >
> >> >   i suspect i'll boot off of the CD and poke around, but i'm open
> >> > to suggestions -- why would this have happened?  and is there
> >> > *something* that will get me to GRUB?
> >>
> >> reinstall grub.
> >
> >  i'm not sure why that would solve the problem since i can
> > certainly boot any of my *older* kernels, suggesting that GRUB
> > itself is fine. it's just building a new kernel from the canonical
> > kernel source tree that gives me an unbootable system -- to the
> > point where i can't even stop in GRUB during the boot process to
> > select an earlier, working kernel.
> That does not make sense to me, you say you can boot the older
> kernels, but also say that you cannot stop in grub to in order to
> boot into the older kernel.  If you cannot get into grub, even
> before it tries to load the kernel, then does that not mean that it
> is a grub issue?
> Colin

  it makes no sense to me, either, but i think you may have
misunderstood.  when i have nothing but older (and ubuntu-packaged
kernels), pressing SHIFT early lets me into GRUB where i can pick the
kernel i want to run.

  when i install this new kernel, SHIFT no longer appears to work so i
can't even select an older, working kernel, the new kernel boots, and
fails.  if i manually edit /boot/grub/grub.cfg to remove the
references to the new kernel, i'm back to having a working system.

  i'm confused since GRUB shouldn't operate this way, of course.



Robert P. J. Day                               Waterloo, Ontario, CANADA

        Top-notch, inexpensive online Linux/OSS/kernel courses


More information about the ubuntu-users mailing list