How to change permissions for /usr/share

Xandros Pilosa folivora.pilosa at
Sat Jan 23 13:05:31 UTC 2010

Dne 23.01.2010 (sob) ob 19:45 +0900 je Thomas Blasejewicz zapisal(a):
> Good evening
> Ubuntu comes apparently with "Stardict" pre-installed.
> I would like to see how this software works and therefore tried to
> download -> install some dictionaries.

Hello Thomas,

I suppose you installed stardict from ubuntu repositories.
Did you see suggestions for installing additional dictionaries in

> However, the dictionary files are supposed to be put into the folder
> /usr/share/stardict/dic (it says so in the software itself)
> Yet, when I try to
> * download something to that location
> * copy previously downloaded compressed files
> * copy decompressed folders or files
> I always get an error message (in Japanese, since I use the Japanese
> localized version),
> telling me, that I have no right to modify/access the above mentioned
> folder.
> Under "owner" it says there "root".

Like it should and this is for a reason.
(See links in reply to your post with subject "How to indicate paths"
about file system tree.)
> I tried to change the permissions, but all options are greyed out and I
> cannot change anything.
> I also tried "Alt+F2 -> sudo", but had no access.
You may find useful to get some references about sudo and gksu (kdesu
for Kde) and their usage.
Two of them [2] and [3] are linked below and you can always see what
commands man sudo and man gksu or man kdesu reveal for you.

> If I am supposed to put the relevant dictionary files into that
> directory, how do I actually put them there
> when the computer does not allow me to modify the contents?
> Thank you.

In the link [1] are exact instructions how to do that.



More information about the ubuntu-users mailing list