Beginner Q1: Linux incapable of handling FDD? CONCLUDED

NoOp glgxg at
Tue Jan 19 01:27:42 UTC 2010

On 01/17/2010 02:05 AM, Thomas Blasejewicz wrote:
> Good evening
> Thank you for all your advice.
> Apparently many people CAN use floppys - I cannot; after trying for 
> several months.

Who are you replying to? Your post is threaded as in reply to my post,
but the following is nothing that I wrote.

I provided you advise on floppies via 8.04 & issues with 9.10. Dave
Woyciesjes provided you with his experience with 9.04.

In another thread you go on a bit of a diatribe regarding living in
Japan for 30 years (I lived there for 5 years if that matters), tell the
list that "about 10 different "versions" (Ubuntu, Suse, Debian, Mandriva
...installed using vaious combinations of hardware)" and yet you can't
get a floppy to mount in 9.10 via the information provided?

In the future, you might wish to: 1) attribute your responses to the
person you are replying to [1], 2) detail what happens when you've
actually *tried* the recommendations of others, and 3) read what others
have posted, including the bug issues.

My opinion: nobody minds assisting; otherwise I and others wouldn't have
bothered looking into the bug report(s) and providing out feedback &
tests. Have a little consideration for others please. Eliminate the
nonsense about being stupid (baka) & what did, or didn't work in some
other distribution, and simply state your problem, detail what you have
or have not done, and leave it at that.


[Note: left the rest of the post intact so some of the above may make
sense to someone reading it later. My apologies to the list for not

> "When you say you can't get your Floppy diosk drive to work in Linux
> what exactly are you trying to do with it?" -> Just pop a FD in, read, 
> write, maybe format it, pop it out. That's it.
> "Start a terminal window from "Applications -> Accessories -> Terminal" 
> and type the command)
> 1) Output of "uname -a"
> 2) Output of "lspci"
> 3) Output of "lsmod -a"
> or
> sudo mkdir /mnt/floppy
> sudo mount /dev/fd0 /mnt/floppy"
> Well, I did ask the same question before on the OpenSUSE forum and went 
> through a very long list of such instructions that in the end became so 
> technical that I could not follow any longer.
> This question of mine actually started a sort of holy war among the 
> users there about what is right and what wrong. So, in the end I 
> withdrew my question and apologized to the list for asking it.
> Both my hardware (FDD) and the disks themselves are fine. Verified.
> Under SUSE following one of the advised very complex procedures I 
> actually succeeded in reading a floppy once. Every second effort failed.
> The official documentation (for SUSE that are 4 PDF files with a total 
> of 1000 pages) and a number of reference books I downloaded actually do 
> not show any information pertaining to "mounting a floppy" (as far as I 
> could find). I tried to search for things like "format a floppy". 
> Information = 0.
> There appear to be quite some problems.
> This is what I cannot understand: FDD are "ancient" devices that should 
> NOT pose any technical problem. Pop in a floppy, read it. That is 
> something I did on many computers using several OS in the past 25 years 
> and never even heard of this being able to cause problems (unless the 
> machine is broken).
> Conclusion: apparently at least I am too stupid to use floppys under 
> Linux. So, I gave up trying. Although it would be very useful to me, if 
> I were able to.
> I am NOT trying to any other OS, PC etc., but if Linux is really to good 
> (so much better than ...), I think something as simple as using a floppy 
> should be possible - as long as both media and drives are around.
> I consider the matter now closed and really hope, I did not disturb the 
> list too much.

More information about the ubuntu-users mailing list