Beginner Q1: Linux incapable of handling FDD?

NoOp glgxg at
Sat Jan 16 04:53:56 UTC 2010

On 01/14/2010 07:59 AM, Thomas Blasejewicz wrote:
> Ladies and Gentlemen
> You may safely call me a complete beginner (totally ignorant).
> Actually, I am trying to get "linux going" for over 2 years now and am
> not getting anywhere. This probably proves that I must be extraordinary
> stupid.
> So, please bear with me, when I sometimes sound frustrated.
> Question 1: for confirmation.
> Recently I have (tried to) used OpenSUSE (10.3 / 11.1 / 11.2) for a
> while and am now trying to use Ubuntu (9.10)
> The computer I use exclusively for experimenting with Linux does has a
> functional FDD. I tried to use it under OpenSUSE, asked the relevant
> question on a SUSE mailing list, then tried to use it under Ubuntu
> (Japanese version).
> Apparently Linux CANNOT handle floppys and someone pointed out, that
> this is a "bug":
> == Regression details ==
> Discovered in version: Karmic Koala 9.10
> Last known good version: Jaunty Jackalope 9.04
> So, just to confirm: is it really so, that Linux is incapable of
> handling a FDD???
> Since this is a task every computer on the planet could do that over the
> last three decades, I do have difficulties believing that this can be so
> incredibly complex. Even though floppys may be considered by some people
> to be "behind our time".

As you'll see from the comments in this thread, and also:
<> see
my comment #174.
That linux does indeed handle floppies. However something in doing so
got broken in karmic (9.10) that _hopefully_ will be fixed. In the
interim, there are workarounds (albeit not eloquent) that enable you to
mount the floppy, and to format (kfloppy works/gnome-disk-utilities does

Note that you'll also still run across this bug (marked as invalid due
to it being a duplicate of which
is *still* not fixed):
[Floppy name does not change without reboot]
[Floppy drive label icon changes to "1,5 GB Media" and don't go back to
"Floppy Drive" anymore]

Suffice it to say that floppy support in Ubuntu & Gnome in general is
sorely lacking...

More information about the ubuntu-users mailing list