dd problem

charlie derr cderr at simons-rock.edu
Wed Jan 13 20:25:19 UTC 2010

> charlie derr wrote:
>> Karl F. Larsen wrote:
>>> Georg von Zengen wrote:
>>>> so you have to delete it, chose another name or creating a new file in
>>>> "nita". dd can only write into files e.g.
>>>> sudo dd if=/dev/sdb1 of=/media/disk/nita/sdb1 bs=2048 conv=notrunc

OK, first problem, you appear to have quoted me, but you've snipped out
all of what I typed (and a lot of other important stuff).  For instance
what you typed.  Which is that you didn't believe that command was going
to work.  So why respond to it this way?  Sorry but it's hard to
communicate with you no matter how hard I want to succeed at it.

> 	Now a couple of what happened problems. Again this is on
> Ubuntu 9.04 using a 160 GB portable HD in a box made by ADS
> Tecnologies, China.
> 	My first question is: Why does dd ruin a file system when it
> is directed to put some files on the HD?

Because you ignored the advice above and fumbled around trying things
instead.  If you'd actually executed the command Georg suggested (at the
time Georg suggested) it would have worked as expected.

> The HD had ext3 file
> system and it was shown as /media/disk then. Then I used dd to
> get as much as possible from a bad HD and put it on the
> portable HD. It did but it ruined my portable system! Now when
> plugged into this computer it showed as /media/CEE.

It's all about you gaining an understanding of the difference between
partitions and filesystems and how things that live at /dev can be either
(it's up to the intelligence and knowledge of the user to distinguish

> 	After getting the stuff on another computer I tried to fix
> the portable. I tried to remove CEE. I did remove most of it
> but not all. Took the HD out of the portable and onto this
> computer. Here I used Partition Editor to see this HD. It said
> the HD has a ntsf file system and no sign of any ext3.

This totally makes sense to me.  In the reply you snipped I already
explained that you had made an exact copy of your computer.  Obviously
that computer had an NTFS filesystem on it.  Now it's on your portable
(and that's all that's on the portable because you told dd to overwrite
everything else the way you executed your command.

> To fix
> this I had to delete the partition and then re-make a new ext3
> file system.
> 	Another question. I backed up all of /home/karl which is now
> about 25GB with dd. It worked fine and when complete I looked
> at /media/disk and ls and ls-al both said there is nothing on
> the portable HD!  I unmounted the portable and turned it off,
> and then back on. Looked and sure enough the backup was on the
> portable as I expected! Why didn't it show up right after dd
> was complete?

I don't know the answer to that one.  Maybe someone else has a clue.

    be well,

> 73 Karl
> --
> 	Karl F. Larsen, AKA K5DI
> 	Linux User
> 	#450462   http://counter.li.org.
>          Key ID = 3951B48D
> --
> ubuntu-users mailing list
> ubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at:
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

More information about the ubuntu-users mailing list