dd problem

Karl F. Larsen klarsen1 at gmail.com
Wed Jan 13 19:44:28 UTC 2010


charlie derr wrote:
> Karl F. Larsen wrote:
>> Georg von Zengen wrote:
>>> so you have to delete it, chose another name or creating a new file in
>>> "nita". dd can only write into files e.g.
>>> sudo dd if=/dev/sdb1 of=/media/disk/nita/sdb1 bs=2048 conv=notrunc
>

	Now a couple of what happened problems. Again this is on 
Ubuntu 9.04 using a 160 GB portable HD in a box made by ADS 
Tecnologies, China.

	My first question is: Why does dd ruin a file system when it 
is directed to put some files on the HD? The HD had ext3 file 
system and it was shown as /media/disk then. Then I used dd to 
get as much as possible from a bad HD and put it on the 
portable HD. It did but it ruined my portable system! Now when 
plugged into this computer it showed as /media/CEE.

	After getting the stuff on another computer I tried to fix 
the portable. I tried to remove CEE. I did remove most of it 
but not all. Took the HD out of the portable and onto this 
computer. Here I used Partition Editor to see this HD. It said 
the HD has a ntsf file system and no sign of any ext3. To fix 
this I had to delete the partition and then re-make a new ext3 
file system.

	Another question. I backed up all of /home/karl which is now 
about 25GB with dd. It worked fine and when complete I looked 
at /media/disk and ls and ls-al both said there is nothing on 
the portable HD!  I unmounted the portable and turned it off, 
and then back on. Looked and sure enough the backup was on the 
portable as I expected! Why didn't it show up right after dd 
was complete?


73 Karl


-- 

	Karl F. Larsen, AKA K5DI
	Linux User
	#450462   http://counter.li.org.
         Key ID = 3951B48D





More information about the ubuntu-users mailing list