File transfer problem

Alex Janssen alex at
Sun Jan 10 22:43:39 UTC 2010

Karl F. Larsen wrote:
> 	Consider this: you have a hard drive in a small case with a 
> lot of files on an ext3 file system that is accessed via a USB 
> port. You plug the USB into a Ubuntu 9.04 computer and a panel 
> comes up showing all the files. You plug the USB into WinXP it 
> shows up in My Computer but shows no files.
> 	So you take the files to the Ubuntu but there is no way to 
> put them in the /dev/sda5 partition. I tried sudo cp -a * 
> /dev/sda5 and it errors out.
> 	Then I tried to mount the /dev/sda5 at /mnt but that fails 
> too. The call I tried was $ sudo mount -t vfat /dev/sda5 /mnt 
> and changed vfat to ntsf and several others and just got an 
> error message.
> 	What I would like to do is copy the files on the little hard 
> drive to the computer which has WinXP and Ubuntu 9.04 in the 
> /dev/sda5 partition.
> 	Does anyone have an idea how to start?
> 73 Karl
One more point on this ...
When you plug the USB drive into the Ubuntu machine it should auto-mount 
on /media/disk or media/name where name=the volume label of the usb 
drive.  The file browser started up showing you the mounted file system 
as that is the default action.  That action can be changed via the 
preference settings, from the menu Edit->Preferences in Nautilus.

cp -auv /media/name ~
  should create the directory name in your home directory with all your 
files in it.

Windows cannot read an ext3 file system, so as Chris said install a 
special program to read from within Windows, namely ext2IFS1_11.exe.


 Only two things are infinite, the universe and human stupidity, and I'm not sure about the former. - Albert Einstein (275)

More information about the ubuntu-users mailing list