no soundcards found 9.10 upgrade on Dell studio xps

Ron Burns rrburns at
Thu Jan 7 20:19:17 UTC 2010

Ron Burns wrote:
> NoOp wrote:
>> On 01/07/2010 10:35 AM, Ron Burns wrote:
>>> NoOp wrote:
>> ...snips
>>>> Something doesn't sound right (no pun intended):
>>>> Changelog
>>>> alsa-utils (1.0.20-1ubuntu1) karmic; urgency=low
>>>>  .
>>>>  .
>>>>  .
>>>> - Set sane level for headphone 1 for Dell Studio XPS with 2.6.30.
>>>> That indicates that sound _should_ be working with your Dell Studio XPS.
>>>> Have a look through:
>>>> <"Dell+Studio+XPS">
>>>> And this one indicates some sound problems, but the sound card is detected:
>>>> [No sound for Dell Studio XPS 1640 laptop]
>> ...snips
>>> OK - I am now getting more confused:
>>> gnome-device-manager tell me: (null) sound card
>>> lshw finds:
>>>          *-multimedia
>>>               description: Audio device
>>>               product: MCP79 High Definition Audio
>>>               vendor: nVidia Corporation
>>>               physical id: 8
>>>               bus info: pci at 0000:00:08.0
>>>               version: b1
>>>               width: 32 bits
>>>               clock: 66MHz
>>>               capabilities: pm bus_master cap_list
>>>               configuration: driver=HDA Intel latency=0 maxlatency=5 
>>> mingnt=2
>>>               resources: irq:17 memory:f0880000-f0883fff
>>> ------
>>> <wee> (ron) uname -a
>>> Linux wee 2.6.28-16-generic #55-Ubuntu SMP Tue Oct 20 19:48:24 UTC 2009 
>>> i686 GNU/Linux
>> <quote>
>> I recently upgraded my Dell studio xps laptop (which shipped with 9.04)
>> to 9.10. I now have no sound.  No soundcard is detected:
>> </quote>
>> 2.6.28-16-generic is a jaunty (9.04) kernel, not an karmic (9.10) kernel:
>> <>
>> The latest karmic kernel is: 2.6.31-17-generic
>> So, either you purposely booted to the jaunty kernel at the grub menu,
>> or your upgrade didn't complete properly. My _guess_ is the latter.
>>> Above "sane level for headphones" comment is for : Dell Studio XPS with 
>>> 2.6.30. Which seems to be consistent with Ubuntu's statement that the 
>>> audio driver was not in my kernel but was a "oversite" that would be 
>>> fixed in future upgrades/updates as it appears to be in 2.6.30.
>>> Update Manager does not show me that 2.6.30 is available.  
>> That is because you are still running jaunty:
>> Should I be
>>> trying to upgrade to this.  
>> I think that you should describe how you went about the 'upgrade' & then
>> we can try to sort it out from there. Also, please provide the exact
>> Dell Studio XPS model that you have.
>> ...
>> And: no need to bcc me directly on your reply, I read the list regularly :-)
> I just rebooted the computer and checked "Update Manager" and now I see 
> there are updates for xxx-2.6.31-17 available. I am going to run these 
> updates now and will post the results.
> Ron

I ran these updates and all seemed to go Ok. I rebooted as asked and 
updated kernels do not show up in the boot up menu.  So I was still in 
2.6.28-16-generic. Next I ran

sudo update-grub

This found several kernels including 2.6.31-17 and the other update I 
did a week or so ago.  I figured I was home free and rebooted.  BUT new 
kernels are still in in menu list at boot up.

Here is boot directory

5 /boot >ls
abi-2.6.28-16-generic	      memtest86+.bin
config-2.6.31-16-generic      vmcoreinfo-2.6.28-16-generic
config-2.6.31-17-generic      vmcoreinfo-2.6.31-16-generic
grub/			      vmcoreinfo-2.6.31-17-generic
initrd.img-2.6.28-16-generic  vmlinuz-2.6.28-16-generic
initrd.img-2.6.31-16-generic  vmlinuz-2.6.31-16-generic
initrd.img-2.6.31-17-generic  vmlinuz-2.6.31-17-generic

and part of the uncommented part /boot/grub/menu.lst is

title		Ubuntu 9.10, kernel 2.6.31-17-generic
uuid		683594d9-8c16-4a27-93e0-fd9a95966991
kernel		/boot/vmlinuz-2.6.31-17-generic 
root=UUID=683594d9-8c16-4a27-93e0-fd9a95966991 ro quiet splash
initrd		/boot/initrd.img-2.6.31-17-generic

title		Ubuntu 9.10, kernel 2.6.31-17-generic (recovery mode)
uuid		683594d9-8c16-4a27-93e0-fd9a95966991
kernel		/boot/vmlinuz-2.6.31-17-generic 
root=UUID=683594d9-8c16-4a27-93e0-fd9a95966991 ro  single
initrd		/boot/initrd.img-2.6.31-17-generic

title		Ubuntu 9.10, kernel 2.6.31-16-generic
uuid	.... <rest not shown>

The updates seem to be there but none of this shows up during bootup. 
Hopefully, if I get booted up into the latest kernel the sound issue 
will be solved.


R. R. Burns
Physicist (Retired)
Oceanside, CA

More information about the ubuntu-users mailing list