CUPS Printer Support Not Working...

Fred Roller froller at
Wed Sep 23 15:23:27 UTC 2009

Joseph wrote:
> I'm using the Jaunty Jackalope.
> I tried to use my XSane Image Scanning program, which had worked, and 
> got a "No devices available" error.
> I looked at the printer configuration at System/Administration/Printing 
> which says the printer is "Not Connected"
> When I try the Printing Troubleshooter, I get the following:  "CUPS 
> Service Stopped"  Below this, it says "The CUPS print spooler does not 
> appear to be running.  To correct this, choose 
> System->Administration->Services from the main menu and look for the 
> 'cups' service.
> It is checked and should be working.
> Now what can I do to get the printer/scanner working (both are not working)?
What is your printer.  That list tells you what will start at boot.

Try from a terminal:

    sudo /etc/init.d/cups restart

Note that this only starts printer services.


"Life is like linux, simple.  If you are fighting it you are doing something wrong."

More information about the ubuntu-users mailing list