remote desktop problem

Patton Echols p.echols at
Fri Sep 18 19:23:30 UTC 2009

I am having some difficulty reaching my desktop computer from my 
laptop.  Currently I am testing on my in house lan, but the goal is to 
be able to reach the desktop from work using ssh.  I am close but can't 
seem to get "the last ten yards." Here is what I've done so far:

On the desktop, used System | Preferences | Remote Desktop to allow 
connection and gave a password. 

I had set this up previously and given a password.  When trying it 
yesterday I received an authentication failure message.  Assuming that I 
had written down the password incorrectly, I reset the password tried 
again, same result.  My attempts to connect from my laptop were:

Attempt #1

patton at laptop:$ vncviewer <ipaddress>:5900
patton at laptop:$ vncviewer localhost:5901
(after connecting via ssh as below)

In each case I do get the authentication dialog that asks for a 
password, but then fails.  So the vnc server is running, but . . .  My 
two thoughts are these:  First, that the new passwords are not read, as 
if the vnc server needs to re-read them, but I can not find a way to 
force that to happen and can't find a server process.  (ps -e | grep vnc 
does not return anything, nor does ... rdesktop or anything else I could 
think of.) 

Second, in another thread someone said to be sure to turn off compiz.  
Ok, how do I do that?  And then turn it back on?  W/o breaking 
something?  The only thing I could find was the suggestion to  "metacity 
--replace"  I tried this assuming that if metacity was not installed, it 
would just say "bash: metacity: command not found"  Well, the command is 
there and broke the desktop, I had to logout and back in to fix it. 

Attempt #2

I installed tightVNC on the desktop, created a password.  Then connected 
like this:

patton at laptop:$  ssh -C patton at -L 5901:localhost:5903

Then started vncserver
patton at desktop:$ vncserver :3

Then from a separate terminal window;

patton at desktop:$ vncviewer localhost:5901

This works, but the problem is it does not give my existing desktop, it 
gives a new desktop.  What I want is to be able to interact with the 
desktop I left behind.

I get the same result if I ssh in using  -L 5901:localhost:5901  I think 
that the existing desktop is desktop "0:  But if I try and start 
vncserver :0 I am told that a vnc server is already running on desktop 
0.  I think it must be the "remote desktop", but as noted above, I can't 
figure out how to kill the existing server to use another one.

So are there thoughts about what I am doing wrong? 


More information about the ubuntu-users mailing list