Wireless: network detected, but no connection

NoOp glgxg at sbcglobal.net
Tue Nov 10 21:08:48 UTC 2009

On 11/10/2009 04:23 AM, Frank Lorenz wrote:
> Meanwhile, I have new information about this problem and maybe there is
> some hope. :-)
> As i told in one of my previous post, this Wlan-stick worked on an old
> laptop with Ubuntu 8.04.
> Today I tried to run Ubuntu 8.04 from a live-cd and obtained the same
> behavior: wireless network detected, trying to connect and failure about
> a minute later. :-(
> But, and here is the interesting part of the story, by clicking on the
> NetworkManager icon, I selected the "Manual Configuration" and disabled
> the "Roaming mode" by un-selecting  the "Enable Roaming Mode" option. At
> this point, the other fields are un-grayed and I manually entered the
> network name (ESSID) and selected "Automatic configuration (DHCP)
> option.
> The default value in the "Password type" option is "WPA Personal". The
> other possible options are "WEP Key (Hexadecimal)", "WEP Key (ASCII)"
> and "WPA2 Personal". There are NOT other options like "No Security" or
> similar. I left selected the default value "WPA Personal" and simply
> left the "Passsword" field blank.
> After clicking "OK", a short "Changing Interface configuration" appeared
> and... surprise surprise... the computer connects perfectly to the
> wireless network. I was able to surf the web using Firefox and to ping
> other machines without any problem! Wow! :-))))
> OK, at this point I'm sure that the Wlan-sticks are not defective, it is
> not a driver problem, it is not an interference or poor signal problem
> and it is not a hardware problem. That's the good news!
> The bad news is that I'm not able to replicate the same procedure on
> Ubuntu 9.10. By manually editing the network connection (on NM), if I
> select "No Security", the connection attempt fails as described in my
> original post. 
> If I select anything else (WPA, WEP,...), the GUI does not allow to
> leave a blank password field. 
> And there is no "Enable Roaming Mode" option to select or deselect.
> Any ideas now?  :-)

I set my router temporarily to no security & changed the essid to 'x'.
Then using wicd:

$ sudo /etc/init.d/wicd stop
$ gksu gedit /etc/wicd/wireless-settings.conf
and deleted everything in the file
$ sudo /etc/init.d/wicd start

Then I opened the wicd manager & connected to 'x'. No issues connecting
at all & here is the resulting wireless-settings.conf data that wicd
rewrote back into the file:

[<mac address>]
afterscript = None
bssid = <mac address>
ip = None
dns_domain = None
quality = 75
gateway = None
use_global_dns = 0
strength = -57
encryption = False
bitrates = 6 Mb/s
postdisconnectscript = None
beforescript = None
hidden = False
channel = 1
mode = Master
has_profile = False
netmask = None
predisconnectscript = None
enctype = None
dns3 = None
dns2 = None
dns1 = None
use_settings_globally = 0
use_static_dns = 0
essid = x
search_domain = None

I've of course set the router et al back to wpa2 & that's also working
w/o issue.

I'll load up network manager in awhile & repeat the the test with NM.

More information about the ubuntu-users mailing list