cifs mount not working after 9.10 upgrade

Joep L. Blom jlblom at
Sun Nov 1 13:50:12 UTC 2009

Chris Jones wrote:
> On 1 Nov 2009, at 12:44am, Joep L. Blom wrote:
>> Chris Jones wrote:
>>> Hi,
>>>> I have just upgraded to the new 9.10 release and my smb connections
>>>> work
>>>> automatically. I don't need to do a mount.cifs to see my shared
>>>> directories on my Windows systems. To be correct I haven't tried a
>>>> mount.cifs for obvious reasons.
>>> I think it depends on the accessibility your shares have - If they
>>> don't require a login  then your approach probably works fine.  Mine
>>> do, and I have only ever been able to get them mounted with the full
>>> mount.cifs command I posted earlier, with access credentials.
>>> Chris
>> Chris,
>> They require a login but I have Linux and Windows users shared and a;;
>> users are also users on the main server.
> Thanks. One other thing - Are you mounts available at the command line  
> or only in some GUI file browser like nautilus. I know that fine  
> managers these days do often provide auto-mounting of remote file  
> systems like this, smb, sshfs etc., but these mounts are only visible  
> in the file manager. I want them mount like any other proper  
> filesystem, at the command line.
> So, just out of interest how exactly do you mount your shares, and how  
> are they visible ?
> cheers Chris

As you guessed, I use it under X and the directories are mounted using 
the standard tools from samba which are now incorporated in a.o. nautilus.
But just out of interest I tried to mount from the commandline and found 
that mount.cifs has disappeared. I assume the developers in their 
infallible wisdom developed some other script (or changed the name) but 
forgot to mention it. It would be nice if somewhere a notice had 
appeared that mount.cifs was depreciated just as the good old mount.smb 
has been depreciated and replaced by mount.cifs (and also mount.smbfs).
I have a running Hardy and there mount.cifs and mount.smbfs are still 
available. What happened with it in Karmic I don't know. I have the 
impression that canonical is more and more trying to hide the real 
processes from the user and urges him to use the graphical layer only. 
It makes it more equal to commercial OSes like M$ OS and Apple (which is 
  Unix based on I think BSD hidden under the apple look) but it makes 
life for normal(?) (more technical) users harder.
Just my 0.02 €.

More information about the ubuntu-users mailing list