What pgm reads the /etc/network/interfaces file? (Installation WPA worked great! Too bad I messed with it!)

Charles Smith cts.private at yahoo.com
Mon Jun 29 20:13:04 UTC 2009

--- On Sun, 6/28/09, NoOp <glgxg at sbcglobal.net> wrote:

> From: NoOp <glgxg at sbcglobal.net>
> Subject: Re: What pgm reads the /etc/network/interfaces file? (Installation WPA worked great! Too bad I messed with it!)
> To: ubuntu-users at lists.ubuntu.com
> Date: Sunday, June 28, 2009, 2:49 PM
> On 06/28/2009 01:17 PM, Derek
> Broughton wrote:
> > NoOp wrote:
> > 
> >> There are issues with NM:
> >> <https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/339046>
> >> [Wireless WPA key corrupted]
> >> <https://bugs.launchpad.net/ubuntu/+source/network-manager/+bug/291260>
> >> [seahorse does not show original wpa passphrase]
> >> http://bugzilla.gnome.org/show_bug.cgi?id=557382
> >> [WPA password changes into hash, not properly
> stored]
> >> 
> >> Were I you, I'd look into installing wicd...
> > 
> > Oh God, I hear that music playing again.  Sure
> there are issues with 
> > NetworkManager - but there are issues with Wicd too,
> and it's not as well 
> > supported by Ubuntu.  I see 14 bugs filed against
> wicd, all but 1 one of 
> > them still "New" - they're not getting much
> action.  Network-manager has far 
> > more open bugs (565) but 60% of them are getting
> _some_ attention.
> > 
> > Sure, go ahead install wicd but don't expect to be
> able to get much help if 
> > it doesn't work.
> It was a _suggestion_ to _look into installing wicd_. He
> was also
> provided with links to bugs that may, or may not, assist
> him in figuring
> out the issue with NM. There was no "music playing", simply
> advise. If
> you have something better to advise to help the OP sort out
> the problem,
> then please post it.

In fact, it was right on (although I still don't have a solution).  These bug reports are very similar to my problem.

I think I'm going to try a little longer with the default installation for now though, unless I really can't get it to work.  It doesn't seem like it should be so hard...

I actually have a feeling for what's going on ... I'll bet that the wpa passphrase is stored somewhere else in /etc by the default installation, but that NetworkManager re-writes the /etc/network/interfaces file in a way that disconnects it from the original automatic authentication mechanism ...


More information about the ubuntu-users mailing list