printing via serial to usb cable

Wade Smart wadesmart at gmail.com
Wed Jan 28 15:42:45 GMT 2009


Karl F. Larsen wrote:
> Wade Smart wrote:
>> 20090128 0906 GMT-5
>>
>> I recently posted about my parallel to usb cable causing lots of 
>> problems on my system - and since I received no help there I decided to 
>> try something else.
>>
>> I borrowed a serial to usb cable. I was able to print a test page by:
>> sudo echo "Printer Test" > /dev/ttyUSB0
>>
>> but I havent been able to print any other way.
>>
>> In cups I changed the uri to usb://dev/ttyUSB0 and then I ran the 
>> configure script but nothing changed.
>>
>> What else can I try?
>>
>> Wade
>>
>>   
>     The problem your having is VERY POOR devices to convert an old 
> Parallel port to a USB port. This is just a terrible thing to design! 
> You have data arriving in parallel and sent out in serial by the USB 
> port. The converter has to process the data bits fast enough to get it done.
> 
> 
>     Now going from Serial to USB is a much better thing to design. But 
> you need to remember that the serial port has some weird things hard for 
> the USB port to handle. But if you got it to work at least once, go to 
> the printer setup system and set it for a serial port and I may work.
> 
> 
> Karl
> 
> 

20090128 0932 GMT-5

In cups I have the uri set to the above.

Running lsusb:
Bus 002 Device 082: ID 05ad:0fba Y.C. Cable U.S.A., Inc.

The driver that worked for the parallel to usb was the HP LaserJet 4050 
Foomatic/hpijs.hpijs 2.8.2.10 - HPLP 2.8.2 [en].

In cups:
Device: gives me a drop down list with the first one being AppSocket/HP 
JetDirect - which Im assuming is the right one to use.

Wade

-- 
Registered Linux User: #480675
Linux since June 2005




More information about the ubuntu-users mailing list