Is it possible to manually activate an eth0 connection?

Bas Roufs basroufs at
Wed Jan 21 12:08:52 UTC 2009

Dear Everybody

Thanks for all your useful advise so far. However, I still get stuck
in my attempts to connect my laptop to the internet. In this message,
I summarise how recent advises from some amongst you worked out in the
case of Kubuntu 8.10 at my laptop - a Medion 5400, 40 GB, Pentium 4/
2,5 Ghz processor.

I start with the file /etc/network/interfaces.

> > auto lo
> > iface lo inet loopback
> modify the file to include _only_ those two lines. You can comment out
> the rest by placing a # in front if you wish:
> # auto eth0
> # iface eth0 inet static
> # address
> # netmask
> # gateway
> or delete them. It does not matter.

After carrying out this advise in at least 2 ways, I did not manage
any more to ping my router ( and desktop (
The 'destination host' was in both cases 'unreachable', according to
the Unix terminal feedback. Also an attempt to ping an external
website ended up in an 'unknown host' feedback.

That's why I have re-edited etc/network/interfaces back to as it was
at the 19th of January:

auto eth0
iface eth0 inet static

After saving the file re-edited like this, I manage again to "ping"
the router and desktop. The terminal test feedbacks were again like
those in the alinea after this one. "^C" = the control-C command meant
to manually stop the 'ping' process. (Thanks for that idea, NoOp!)

bas at Viaconsensus2:~$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=254 time=1.00 ms
64 bytes from icmp_seq=2 ttl=254 time=0.971 ms
64 bytes from icmp_seq=3 ttl=254 time=1.00 ms
--- ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2007ms
rtt min/avg/max/mdev = 0.971/0.993/1.008/0.015 ms

However, I still do not yet manage to ping or any other
external website. At a terminal, the fruitless attempt looked like
bas at Viaconsensus2:~$ ping
ping: unknown host

With respect to the /etc/network/interfaces file, an advise came in to
replace this: ...
> iface eth0 inet static
...with this:
> iface eth0 inet dhcp
After doing so, attempts to ping my router ('unreachable'), desktop
('unreachable') and an external website ('unknown host') were all
That's why, I put back 'inet static' in the interfaces file. After
doing so, attempts to ping the desktop and router were successful, but
pinging still did not work out.

A core issue is now, whether it is possible to manually configure an
eth0 connection via 'KNetwork', the network manager of Kubuntu 8.10.
With respect to this issue, this advise recently came in:

> Now open the intrepid network manager and click on the Wired tab and
> entry for "Wired connection 1" then click "Edit". In IPv4 Settings:
> Method: Manual
> Addresses:
>  Address -
>  Netmask -
>  Gateway -
> DNS Servers: enter the dns servers for your ISP ...
With respect to this issue, I get this info via
NameServer: NS3.NIC.FR
NameServer: SEC1.APNIC.NET
NameServer: SEC3.APNIC.NET

The same site clarifies the "external IP" of my DESKTOP
PC, from which I am writing this message:
At a terminal on the desktop, I carried out a dig test with this IP
number. This was the outcome:

bas at Viaconsensus1:~$ dig
; <<>> DiG 9.5.0-P2 <<>>
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 34038
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;                        IN      A

.                       10800   IN      SOA     A.ROOT-SERVERS.NET.
NSTLD.VERISIGN-GRS.COM. 2009012000 1800 900 604800 86400

;; Query time: 28 msec
;; WHEN: Tue Jan 20 12:11:19 2009
;; MSG SIZE  rcvd: 107

If I understand you correctly, NoOp, my 'DNS' should be, as a matter
of consequence: "".
In KNetworkmanager, the manual menu for wired connections contains two
lines I need to fill in with respect to DNS: 'DNS Addresses' and 'DNS
Search'. First I filled in the 'name servers' coming out of in the line 'DNS Addresses' and "" (without
the "-signs) in the line 'DNS Search'. But after saving, closing and
re-opening this output, the 'name server' names in the DNS Addresses
line vanished. Three attempts worked out like that.
Than I put the DNS info inversely: '' in 'DNS Addresses'
and the 'name servers' in 'DNS Search'. KNETWORKMANAGER does maintain
this input after saving and closing. However, even the option 'save
and connect' does not yet result in an effectively working internet
connection from my laptop. On the other hand, it did not harm anything
neither. I still DO manage to ping my router and desktop from the

> Now click on the "Wired" tab and enter the mac address for your eth0
> (from your ifconfig output):
> MAC Address: 00:40:ca:bc:9e:88
> MTU: 1500

In 'KNetworkmanager' I did not find any tab or option to fill in the
'MAC Adress' and 'MTU'. Do I overlook anything? Is there any other
option to manually fill in such information?

> Now click OK. You'll get a password prompt: enter your password.
In KNetworkmanager, it did not work out like this.

>From a terminal at the laptop, I carried out some tests, advised to me
in this thread.

> cat /etc/resolv.conf
The test  "cat /etc/resolv.conf" delivered only this feedback:
# generated by NetworkManager

Then, I tried to run 'NetWorkManager' as root, from the terminal. But
nothing happened: no menu popped up, but also no information about any

> cat /etc/hosts
This test worked out in the feedback below and above the ==== lines.

bas at Viaconsensus2:~$ cat /etc/hosts       localhost       Viaconsensus2

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts

> ping
As mentioned above, this ping test is fruitless:
ping: unknown host

> ping
This test worked out as indicated in between the === lines.

bas at Viaconsensus2:~$ ping
PING ( 56(84) bytes of data.
>From icmp_seq=2 Destination Host Unreachable
>From icmp_seq=3 Destination Host Unreachable
 .....seq=4.....sec=5 ...etc. ...sec=29 Destination Host Unreachable

--- ping statistics ---
29 packets transmitted, 0 received, +21 errors, 100% packet loss, time 28029ms
, pipe 3

This ping test was fruitless. On the other hand: as indicated above, I
DO manage to ping the router and desktop.

> cat /etc/udev/rules.d/70-persistent-net.rules

The outcome of this test in between the === lines.

bas at Viaconsensus2:~$ cat /etc/udev/rules.d/70-persistent-net.rules
# This file maintains persistent names for network interfaces.
# See udev(7) for syntax.
# Entries are automatically added by the 75-persistent-net-generator.rules
# file; however you are also free to add your own entries.

# PCI device 0x10ec:0x8139 (8139too)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",
ATTR{address}=="00:40:ca:bc:9e:88", ATTR{type}=="1", KERNEL=="eth*",

# PCI device 0x115d:0x0003 (xircom_cb)
SUBSYSTEM=="net", ACTION=="add", DRIVERS=="?*",
ATTR{address}=="00:10:a4:75:ba:4a", ATTR{type}=="1", KERNEL=="eth*",

Finally, I provide you with possibly useful information that I got via

External IP: 
(= desktop?)
Proxy:                      No Proxy or Invisible Proxy Used
Internal (LAN) IP:
Outgoing Port: 	12639

ReferralServer:         whois://

NetRange: -
NetName: 82-RIPE
NetHandle: NET-82-0-0-0-1
NetType: Allocated to RIPE NCC
NameServer: NS3.NIC.FR
NameServer: SEC1.APNIC.NET
NameServer: SEC3.APNIC.NET
% Information related to ' -'
inetnum: -
descr: Telfort internet
descr: Internet Service Provider
descr: DSL Customer Network
country: NL
admin-c: GITR1-RIPE
tech-c: GITR1-RIPE
source: RIPE # Filtered

admin-c: MH6157-RIPE
tech-c: RP1269-RIPE
tech-c: MH6157-RIPE
nic-hdl: GITR1-RIPE
mnt-by: WOLADM-MNT
source: RIPE # Filtered

% Information related to ''

descr: Green ISP B.V.
origin: AS5615
mnt-by: WISH-MNT
mnt-by: WOLADM-MNT
source: RIPE # Filtered

To finish this message: nearly 3 days of testing still do not result
in a working eth0-connection from my laptop. So, I hope get some extra
feedback which could possibly enable me to fill in the white spots on
my map...... My next possibility to carry out tests and to get back to
you will be next Saturday or Sunday.

Respectfully yours,


Bas G. Roufs M.A.
Van 't Hoffstraat 1
NL-3514 VT  Utrecht
M. +31.6.446.835.10
T. +31.30.785.20.40
BasRoufs at

More information about the ubuntu-users mailing list