USB thumb drive pulled and icon left on desktop - how do I remove it??

Karl F. Larsen klarsen1 at
Sun Jan 18 12:19:22 UTC 2009

Christian Csar wrote:
> Assuming that when you say you tried to unmount it you mean that you
> right clicked and selected unmount, then you could also try unmounting
> it from the command line i.e. umount /media/disk or something similar. I
> believe that if you mounted it in the first place, then you should not
> need root privileges.
    You are wrong. You must be root to use mount and umount in a 
terminal. There are some GUI things that appear to let a non-root mount 
and umount and they work. But they use a root device to do it.


> Christian
> Jay Ridgley wrote:
>> Folks,
>> Yes, I know, I did it wrong...
>> I did a backup to a thumb drive I had inserted in a USB port. After the 
>> backup task completed and without thinking clearly, I simply pulled the 
>> drive out; now the icon that indicates the 4.1 GB Media is mounted 
>> remains. I have tried to unmount the drive that doesn't work and move it 
>> to trash and that did not work either.
>> If I put the drive back in a new icon pops up and I can unmount it and 
>> that one goes away. The other one just hangs around...
>> Short of logging out and back in (I am not sure that will work either, 
>> since a user swap left it) or restarting my system how do I  go about 
>> removing this critter?
>> Cheers,
>> Jay


	Karl F. Larsen, AKA K5DI
	Linux User
   PGP 4208 4D6E 595F 22B9 FF1C  ECB6 4A3C 2C54 FE23 53A7

More information about the ubuntu-users mailing list