ssh - connection refused

frmas frmas at
Sat Jan 17 18:24:49 UTC 2009

NoOp a écrit :
>> I've tried to connect my office computer (client) to my home computer
>> (server), using ssh, but I always have the same message returned when I
>> run : ssh -p 5317
>> "ssh: connect to host port 5317; Connection refused".
>> When I restart ssh from my home computer (server), I have always the
>> same error message in the auth log file :
>> Jan 16 22:34:45 serv sshd[12379]: error: Bind to port 5317 on
>> failed: Address already in use.
>> (I don't use port 22, and here port 5317 is not the one I use really
>> ;-)), it 's just for the purpose of that message.
>> This is my /etc/ssh/sshd_config file
>> Port 5317
> The first thing to do is ensure that it works with 22 properly. Then
> just change as above to 5317. I've just done this on one of my machines
> after first ensuring that it works with 22 and performing a 'sudo
> /etc/init.d/ssh restart on the 5317 target machine:

Hmmm, from your post and the tests I did, the problem could be somewhere
else, so. I have a local lan, and running from my laptop (homelaptop)
the following command :
ssh -X homeserver -p 5317
it works fine, but the auth log file on the "server", shows a connection
from computer homelaptop with ip So I wonder whether or
not the ssh connection is thru the local network only or thru the
internet first, then thru my local network.
Then, the pb could come from my router, and its configuration. Francois

More information about the ubuntu-users mailing list