Getting dvd to play

Rashkae ubuntu at
Sun Jan 11 20:57:01 UTC 2009

Linda wrote:
>> Could you try one more thing? When you insert a movie DVD in to the
>> drive, you should get an icon on your desktop with a label beneath it.
>> I think you should also get a folder with the same name in /media
>> folder. Let us say it is called /media/MyMovie. If that is so, then
>> please this command (install xine if needed) and see what happens:
>> $> xine dvd://media/MyMovie
>> If all goes well, xine should play your dvd and it would mean your
>> libdvdcss2 is working.
> I installed xine. First of all it solved the problem of the green line 
> that runs across the bottom of the frame. I tried running the original 
> dvd which is Whale Rider I checked out from the library. It gets trough 
> all the legal notices but then stops
> with error The source can't be read. maybe you don't have enough rights 
> for this or source doesn't contain data (eg not disc in drive) (Error 
> reading NAV packet)
> This is what the terminal showed with alot more Get Key  messages
> libdvdread: Using libdvdcss version 1.2.9 for DVD access
> libdvdread: Attempting to use device /dev/scd0 mounted on /media/cdrom0 
> for CSS authentication
> libdvdread: Attempting to retrieve all CSS keys
> libdvdread: This can take a _long_ time, please be patient
> libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x0000018b
> libdvdread: Elapsed time 0
> libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x00000219
> libdvdread: Elapsed time 0
> libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x0003fd4f
> libdvdread: Error cracking CSS key for /VIDEO_TS/VTS_01_1.VOB (0x0003fd4f)!!
> libdvdread: Elapsed time 8
> libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x002a3360
> libdvdread: Elapsed time 0
> Then I tried watching the beginning Harry Potter and Its A wonderful 
> Life they seem to work fine.
> Also yes this is an AMD-64 bit machine
> Thanks
>    Linda

I haven't followed this thread, so forgive if I'm repeating or offering
non relevant ideas.

I propose 2 things to try.

1.  Delete the .dvdcss directory in your home directory.  This directory
keeps a chached copy of dvd css keys for faster access to those same
discs, but strange things have been known to happen if bad data gets in
there somehow.

2.  When you try to play the dvd that doesn't work, use the 'dmesg'
command in a console, and look over the most recent messages for I/O
errors.  It's possible the dvd in question has a damaged area, or that
your DVD drive is simply not able to reliably read this disc.

More information about the ubuntu-users mailing list