rsync error…

Smoot Carl-Mitchell smoot at
Mon Jan 5 23:21:44 UTC 2009

On Mon, 2009-01-05 at 23:18 +0100, Johnny Rosenberg wrote:

> The file mentioned is actually a soft link to a file with the same
> name. Its permissions are "rw-r--r--". I then noticed that all of my
> other links had permissions such as "rwxrwxrwx" or at least
> "rwxr-xr-x", so I thought that thre could be some kind of special
> thing about links or something, so I changed the permissions to
> "rwxr-xr-x" using Nautilus, but I still get the same error message. 

I forgot to add this to my previous post.  Permissions on symlinks are
irrelevant, since you cannot "write" to a symlink, but only create them
with the symlink system call which is used when you use the "ln" command
with the "-s" option.

Most operations on files and their meta data (e.g. open, chmod, etc)
operate on the target of the symlink and not the symlink itself.
Smoot Carl-Mitchell
System/Network Architect
smoot at
+1 480 922 7313
cell: +1 602 421 9005

More information about the ubuntu-users mailing list