Re: rsync error…

Johnny Rosenberg gurus.knugum at
Tue Jan 6 13:38:50 UTC 2009

2009/1/6 Smoot Carl-Mitchell <smoot at>

> On Mon, 2009-01-05 at 23:18 +0100, Johnny Rosenberg wrote:
> > The file mentioned is actually a soft link to a file with the same
> > name. Its permissions are "rw-r--r--". I then noticed that all of my
> > other links had permissions such as "rwxrwxrwx" or at least
> > "rwxr-xr-x", so I thought that thre could be some kind of special
> > thing about links or something, so I changed the permissions to
> > "rwxr-xr-x" using Nautilus, but I still get the same error message.
> I forgot to add this to my previous post.  Permissions on symlinks are
> irrelevant, since you cannot "write" to a symlink, but only create them
> with the symlink system call which is used when you use the "ln" command
> with the "-s" option.

The strange thing is that I have a lot of other symlinks, and rsync only
complains over this particular one…
Do you think I'd be better off if I just removed the symlink and created a
new one?

> Most operations on files and their meta data (e.g. open, chmod, etc)
> operate on the target of the symlink and not the symlink itself.

Yes, I found that out after some testing.
Thanks for your reply. I will do some more testing now, I think.
Johnny Rosenberg

> --
> Smoot Carl-Mitchell
> System/Network Architect
> smoot at
> +1 480 922 7313
> cell: +1 602 421 9005
> --
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list