Atheros wireless problem/ Bash Shell Script

Martin Stephens exogenetic at
Mon Apr 20 02:30:25 UTC 2009

Perhaps I should just be to the point.  My wireless (ar928x chipset w/bluetooth, ath9k driver) has some issues with range.  The range is better in Windows.  The Linux driver shuts down the Windows driver.  When I tried some basic commands to check out what was going on in a fresh install of Jaunty 9.04, a script executed leaving below set of entries in my Bash History.  My bash history is attached, leading period deleted.  This happened without my consent, and I felt it was invasive.  I tried to figure out what triggered it, and could not repeat it.  The script printed out the following lines when I hit return accidentally while typing the "sudo iwlist modul" command.

>From Bash History (attached): 
sudo iwlist
sudo iwlist wlan0 modul
Know a company guilty of software piracy?
Get PAID up to $1 Million for Confidentially Reporting Software Piracy by an organization.
Help Stop Software Piracy with Rewards Offered up to $1 Million!
Minimize IT cost with auto job scheduling and report delivery. Great for businesses of all sizes.
Crystal Reports Server 2008 - Powerful Reporting Made Easy
Try a full version of the industry-leading reporting software free for 30 days.
Crystal Reports 2008 - Powerful Reporting Made Easy.
Business Web Hosting
Get Your Company Up to Speed With Microsoft Web platform. 60 days Free and $100 in Advertising.
Advertiser Here
Connecting to a Wireless LAN with Linux
sudo iwlist wlan0 modulation


To the best of my knowledge, I did nothing to provoke this.  I do not pirate software, nor do I know of any company that does.  I am not interested in business software, and did not solicit this.  This is really kind of creepy.  Will someone please help me work out the issues with my atheros drivers so I can delete my Vista partition?  This is really too much.  I would really like constructive, practical answers.      

Thanks Martin

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: bash_history
Type: application/octet-stream
Size: 3767 bytes
Desc: not available
URL: <>

More information about the ubuntu-users mailing list