Bootup freezes at "Starting up..."

Rashkae ubuntu at
Wed Apr 8 18:05:48 UTC 2009

Michael Peek wrote:
> Hi gurus,
> First of all, I'm attempting something screwy, so a little backstory is 
> probably important.  I have some servers with large (>16TB) RAIDS.  
> Disgruntled with JFS and XFS, I decided to try Ext4.  The servers are 
> running 8.10 amd64 server (linux-image-2.6.27-11-server) and fully up to 
> date.  So I downloaded the source packages for e2fsprogs-1.41.4, 
> linux-2.6.28-11, and wireless-crda-1.7 from the Jaunty tree and compiled 
> them.
> I have two servers:
> Server #1:
> SuperMicro X7DWE
> 2 x Intel Xeon E5420 2.5GHz CPUs
> Adaptec RAID 51645
> Server #2:
> Same as server #1, except with two Adaptec RAID 51645 cards
> On server #1:
> + New kernel
> + wireless-cdra
> + e2fsprogs
> + reboot
> = Flawless victory!
> Formatted the RAID ext4 and it's running like a top.
> So I repeated this process on server #2, but when I rebooted, I was 
> greeted with:
> Boot from (hd0,0) ext3 c7447ceb-e203-418b-9c2b-d76d8d89f99e
> Starting up...
> And then the server hangs.  And by hang, I mean it stayed at that point 
> for an hour and never booted up.
> So I rebooted into the old kernel and edited /boot/grub/menu.lst.  I 
> removed "quiet" and "splash" from the kernel parameters list for the 
> 2.6.28 kernel and rebooted.  The bootup process hangs at:
> [    0.392901] CPU0: Intel(R) Xeon(R) CPU E5420 W 2.50GHz stepping 
> 0...<off screen>
> [    0.400000] Booting processor 1 APIC 0x4 ip 0x6000
> The next thing I tried was noacpi and noapic, no good.  Thinking that I 
> had it wrong, I tried acpi=off and apci=off.  No good.
> As a last resort, I turned ACPI off in BIOS.  No good.
> [    0.013284] Setting APIC routing to flat
> [    0.013344] CPU0: Intel(R) Xeon(R) CPU E5420 @ 2.50GHz 
> stepping...<off screen>
> [    0.130848] Booting processor 1 APIC 0x4 ip 0x6000
> <And... freeze!>
> I am now officially desperate.  Does anyone have any ideas what to do next?

Looks like a kernel issue, so next I would download the latest kernel
source, build it, stick it in Ubuntu, and bring my problem to the lkml.
 I'm not trying to say the discussion isn't welcome here, but following
that path, you stand a greater chance of attracting the attention of
very very knowledgeable kernel hackers to can instruct on on further
troubleshooting steps.  Of course, if pure kernel doesn't have a
problem, then you would need to file a bug report on Launchpad so Ubuntu
kernel team can figure out where they mussed up.

More information about the ubuntu-users mailing list