files sharing SOLVED

Gary Kirkpatrick pegngary at
Sun Apr 5 22:19:02 UTC 2009

On Sat, Apr 4, 2009 at 10:51 PM, Lucio M Nicolosi <lmnicolosi at>wrote:

> On Sun, Apr 5, 2009 at 12:05 AM, Leonard Chatagnier
> <lenc5570 at> wrote:
> >
> >
> >
> > --- On Sat, 4/4/09, Gary Kirkpatrick <pegngary at> wrote:
> >
> >> From: Gary Kirkpatrick <pegngary at>
> >> Subject: Re: files sharing
> >> To: "Ubuntu user technical support, not for general discussions" <
> ubuntu-users at>
> >> Date: Saturday, April 4, 2009, 3:53 PM
> >> On Sat, Apr 4, 2009 at 10:49 AM, Thorny
> >> <thorntreehome at> wrote:
> >>
> >> > On Sat, 04 Apr 2009 09:14:11 -0600, Gary Kirkpatrick
> >> posted:
> >> >
> >> > > I have two laptops each running both windows and
> >> Intrepid.  I need a good
> >> > > guide to activate file sharing and can't seem
> >> to find one.  The one
> >> > > computer is running windows vista, the other xp,
> >> and both have Intrepid.
> >> >
> >> > I don't have a clue why you're having trouble
> >
> > Big snip
> >>
> >>
> >> Thanks again for the list, but none of them solve my
> >> problem.
> >>
> > No expert here, but have you tried setting up smb.conf or are you just
> using the default. Either way, you could post your smb.conf and perhaps
> someone expert in samba can find a problem with it. You do have to specify
> which files you want to share. I always found smb.conf difficult to setup
> properly but NoOP help me get it right but he wont be available til Monday.
> > Have you enabled file sharing in your gnome or kde menus?  Also, windows
> has to have some setup work done also in network interfaces or mounting
> network drives, something to that effect. I believe you also have to have
> the same user name setup in both windows and ubuntu for samba to work
> although some on the list have said no to this but it's the only way I could
> share.
> > Have you tried Nautilus or Dolphin in Ubuntu to see if you can mount or
> connect to server for the files shared on windows. You should be able to do
> this when everything is setup properly and, of course, both machines must be
> running-:))
> > You originally asked for guides but if you want help to get it working
> please provide any error output you see and more detail on just what and how
> you are trying to connect and share files.
> > This may not help much but may get you started. I suspect the answer you
> want is found in the guide references given by Thorny but they may not be
> easy to find.
> > HTH and post back if you still need help, giving details on what you've
> done and any error output.
> > Leonard Chatagnier
> > lenc5570 at
> >
> If I understood correctly, you are not using the full potential of Samba.
> Using Samba is a matter of installing Samba server (samba) and setting
> up a lean and clean sbm.conf. You will also need at least smbfs,
> libpam-mount and libpam-smbpass installed.
> This link provides a nice example of a smb.conf for a simple network.
> The one and only graphical tool I use is Samba Server Configuration
> Tool (system-config-samba). The tool gadmin-samba messed with my
> config in such a way I had to start it all over again.
> I'm no expert but use Samba to share files between Ubuntu 8.10 i386
> and Windows XP machines. I'm currently testing Jaunty 64 beta and up
> to now Samba seems to work. No experience however with Vista.
> --
> Lucio M Nicolosi, Eng. - Sao Paulo - Brazil
> skype: lmnicolosi1
> Lat.:  23°34'4.79"S - Long.: 46°39'59.53"W
> Linux Regist. User #481505 -

I've finally unraveled the mystery.  Having already transfered files between
the xp/ubuntu and vista/ubuntu machine, whereupon I upgraded the former to
Intrepid, I assumed the problem was with Intrepid; shame on me, it turned

I finally decided to check if I could transfer files using XP and Vista.
The XP machine could not see the Vista machine, while the Vista could see
the XP but not open any folders/transfer to/from the XP.  I checked and
somehow the two machines did not share a workgroup name anymore, and changed
that.  Still nothing.  Then I checked to see what else vista needed and it
needed the network to be set to private vs. public.  Somehow that had been
changed as well.   Now I can transfer files between both machines using
either operating system.  And here I was blaming Ubuntu when it was innocent
all along.

However, Intrepid can not see the Vista machine when Firestarter is
enabled.  On to the next mystery!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list