Restore latest kernel

Mike Adolf mlnx at
Thu Oct 16 18:07:32 UTC 2008

Mark Haney wrote:
> Mike Adolf wrote:
>> This morning I ran the latest Ubuntu update.  It installed a new kernel 
>>  I rebooted and all was well.  Then I installed my new pctv 
>> 800i tuner card. To do so, according mythtv wiki, I first extracted 
>> firmware from a windows file and placed it into 
>> /lib/firmware/, I downloaded the latest v4l driver 
>> tree, did a make and make install. This is supposed to overwrite kernel 
>> drivers. When I tried to reboot modprob failed.  It also failed in 
>> recovery mode.
>> Can I some how remove the corrupt kernel, so that auto update 
>> reinstalls it? I an new booted into
>> Thanks,
>> Mike
> Okay, why do you think the kernel is corrupt?  Can you not boot into 
> that kernel at all? It sounds like you can.  Let's try to backtrack to 
> what the problem is before we go about re-installing a kernel.  If 
> there's a module that won't load (or is loading and bombing, we can 
> remove the module listing so it doesn't get autoloaded.  That's quicker 
> and easier.
> What are the errors you're seeing?
I can not boot If I boot it in recovery mode it gets to the 
point of running modprobe and gives the error "abnormal exit" and hangs. 
Recovery mode boot flies by so fast I can't really see what it is doing. 
I can still boot into a previous kernel (.19)


More information about the ubuntu-users mailing list