iPod Nano 3g (green) woes.

Brian Troutwine goofyheadedpunk at gmail.com
Mon Oct 13 23:16:09 UTC 2008

I have been unable to create a proper iTunesDB for my green iPod nano
with banshee 1.2.1, gnupod 0.98.3 or hipo 0.6.1, either through
completely rebuilding the database or by incremental adding. I'm using
Ubuntu 8.04.

Here's the situation: I recently bought a third generation, green iPod
nano for my wife. A single album was loaded onto the device with
iTunes as part of the gift. After a few days she used banshee to
upload more music. No errors were reported and the ejection process
worked correctly. After this point, however, the iPod reported that it
had "No Music". I assume this is because banshee failed to
cryptographically sign the iTunesDB appropriately?

Anyway, I reformatted the iPod with iTunes (which noted that iTunes
was unable to read the device's database) and re-loaded the music
running banshee --debug. No errors were presented and I still recieved
"No Music". Forcing banshee to rebuild the database by deleting it
from the device did not fix the issue.

Moving on to gnupod, I attempted the procedure in section 4.11 of the
manual, recovering lost files. No errors were given during the process
and all went well, seemingly. However, "No Music" still plagued me.
Attempts to use Floola and Yumipod failed, both sigsegv. Copying
albums to the iPod with hipo worked well, up to a point. Being unable
to transcode, hipo could not move approximately half of the music my
wife desired. If I had copied data from the device onto my local disc
and then back this probably(?) have worked, but is not useful in the
long term.

Something is amiss, but I don't know what. Does anyone have ideas or


More information about the ubuntu-users mailing list