New Problem with Movies

Kennneth P. Turvey kt-usenet at
Mon Oct 13 12:21:00 UTC 2008

On Fri, 10 Oct 2008 22:49:35 +0000, Kennneth P. Turvey wrote:

> On Wed, 08 Oct 2008 13:07:53 +0200, Neil wrote:
>> On Wed, Oct 8, 2008 at 7:15 AM, Kennneth P. Turvey
>> <kt-usenet at> wrote:
>>> A few days ago playing video on my system was working fine.. as it has
>>> since my installation on this laptop a few months ago.
>>> Today, I can't play video with either totem or mplayer.  When the
>>> movie starts to play the entire screen becomes either black or gray
>>> and then nothing works...
>>> I think the movie is playing, but I can't see it.  I also can't get a
>>> good X session back by zapping X using ctrl-alt-backspace.  The only
>>> way I get video working again is by actually rebooting the laptop.
>>> I haven't made any updates to the system in the last few days, except
>>> for automated updates that may have come down.  Was X updated
>>> recently?
>>>  Was something else updated recently that would cause this?  Is anyone
>>> else having similar problems?
>>> I'm running Hardy on an Inspiron 1525 by Dell.
>>> Thanks.. any suggestions would be greatly appreciated.
>>> --
>>> Kenneth P. Turvey <kt-usenet at>
>>>  One of the advantages of being disorderly is that one is constantly
>>>  making exciting discoveries.
>>>        -- A. A. Milne
>>> --
>>> ubuntu-users mailing list
>>> ubuntu-users at
>>> Modify settings or unsubscribe at:
>> Hi
>> We probably need some more information. Open a console and type
>> "mplayer -v "your movie file" >> mplayererrors.txt" (replace "your
>> movie file" with the exact path to the file)
>> This'll create a file mplayererrors.txt in your home directory. Could
>> you post the contents of that text file?
>> Neil
> OK, I ran some more tests and came up with a bit more information.
> Totem, VLC, and Mplayer all behave in similar manners.  I uninstalled
> them all, and all the associated codecs, then reinstalled them.  The
> problem persisted.  Mplayer does work on some movie files, but has a
> blue band about an inch high across the top of the window when playing
> these files.  I don't think the entire vertical dimension of the movie
> is displayed, but some of the bottom of the movie is cut off.  If I
> press "f" to switch to full screen mode, then mplayer has exactly the
> same problem as the other viewers, the screen blanks completely and I
> can't get video back without a hard reset of the laptop.  I also found
> that if I attach an external monitor to the laptop, I can then view the
> movies, even in full screen mode.  Under mplayer in this configuration,
> the movie is displayed on the attached monitor, but on the laptop
> monitor, which should display the same thing (although with the right
> and bottom of the screen missing), I see the mplayer window, but with
> only blue in it.
> The following is the contents of the file you specified you needed.  It
> includes the display of the movie with only the blue band issue
> mentioned, and then I hit "f" and get the complete loss of video.  The
> movie continues to play in this condition.  I can still hear the
> soundtrack.
> Thanks for your assistance.

I have a bit more information.  If I run mplayer with the -vo gl2 flag 
then it works correctly on the laptop screen.  I understand that this 
means there is a problem with XV under X.  This doesn't really make sense 
since I haven't fiddled with anything at all, much less the X config 
file.  So, I have to wonder if an update came downstream that messed up 
XV for me?  Any ideas?


Kenneth P. Turvey <kt-usenet at>

  Ninety percent of the politicians give the other ten percent a bad 
        -- Henry Kissinger

More information about the ubuntu-users mailing list