Epson Stylus CX5800F Suddenly Wont Print On Hardy 64Bit Using CUPS+Gutenprintv5.0.2 Simplified

Leonard Chatagnier lenc5570 at
Fri Oct 3 01:55:22 UTC 2008

--- On Thu, 10/2/08, NoOp <glgxg at> wrote:

> From: NoOp <glgxg at>
> Subject: Re: Epson Stylus CX5800F Suddenly Wont Print On Hardy 64Bit Using CUPS+Gutenprintv5.0.2 Simplified
> To: ubuntu-users at
> Date: Thursday, October 2, 2008, 6:15 PM
> On 10/01/2008 09:06 PM, Leonard Chatagnier wrote:
> > Baffling! I've set up this printer and used it on
> several versions of
> > Ubuntu including Dapper, Gutsy and Hardy but now it
> wont work. I have
> > removed and reinstalled the drivers on both Vista and
> Hardy several
> > times and only once after the first reinstall was I
> able to print the
> > test page and self-test page(Hardy) then sending an
> OO.o spreadsheet
> > Income Tax document to the printer it wouldn't
> print anything
> > anymore. I have printed said document on this machine
> with Hardy 64
> > bit using the titled driver many times recently but it
> now wont
> > print. I have 3 printers(same printer) shown in
> Printer
> > Configuration-localhost(using kde 4.1.1) two with
> Device URI: 
> > epson:/dev/usb/lp0 and one with
> usb://EPSON/Stylus%20CX5800F all of
> [snips for brevity]
> > using the right key words.  All drivers for Vista and
> Hardy are the
> > latest. I haven't a clue what is wrong or what to
> try next.
> > Appreciate any advice for a fix and will be glad to
> send any info I
> > may have left out. Setting up a linux Ubuntu printer
> is something
> > I've done a few times all with succes until now. 
> Thanks for any
> > suggestions.
> > 
> > Leonard Chatagnier
> > 
> > lenc5570 at
> > 
> > 
> > 
> OK I'll bite (but only if you promise to set your
> postings to wrap at 72
> chars & use paragraphs).
Don't blame me, blame ATT Yahoo web mail.  They changed up
their email program and I have to do a CR on every line or
it will continue out to infinity.-:)

> My guess is that it's a Republican printer :-)
Absolutely and the Democrats sabotaged it as usual.
I will go over your list with a fine toothed comb and
report back on results.  Some I've done already but some
I didn't think of and that's what I needed; new ideas.
What's baffling is that the printer worked fine a few days
back and suddenly refused to print. My suspicion it's the usb
port or cable.  Will see.

> 1. Have you checked your USB settings: 1) in bios, 2) moved
> the USB to a
> different USB port (back of machine) 3) cable etc? Also try
> a different
> cable & try the same usb cable on an different device.
> USB cables can go
> bad (though not often); trying the cable with another
> device can at
> least verify that the cable is good. If it is then you may
> have a hosed
> USB port on the printer itself.... next time buy a Brother
> or other
> machine with both an ethernet port and a usb port. [1]
> 2. Checked your system logs & lsusb after
> plugging/unplugging the usb
> port? Removed _all_ Epson printers from Hardy's printer
> utility & then
> rebooted and reinstalled just one?
> 3. Tried the printer on a different system?
> 4. Tried the Epson troubleshooting guide? Run a printer
> self test?
> 5. Do you get any error messages on the printer itself? Can
> you you
> print anything from any other program (Vista or Ubuntu)?
> All of the above may seem pretty simplistic/obvious, but
> you never
> know... My guess is that you have a hardware (probably
> cable/usb port
> problem).
> [1] This was a saver when my son's machine got nailed
> by lightening down
> in Florida. His USB cable, the PC USB port, and the USB
> port on his
> Brother MFC were blown. When I put him on Ubuntu (on a
> recycled machine)
> I tested the printer cable and the port, determined them
> bad, and
> instead hooked up the printer to the ethernet port
> connected into an old
> 5 port linksys hub & it's been working perfectly
> ever since.

Leonard Chatagnier
lenc5570 at

More information about the ubuntu-users mailing list