Strange Optical drive problem

Nigel Henry cave.dnb2m97pp at
Thu Nov 6 19:59:51 UTC 2008

On Thursday 06 November 2008 07:54, squareyes wrote:
> Nigel Henry wrote:
> > On Wednesday 05 November 2008 13:35, squareyes wrote:
> >> Nigel Henry wrote:

> > The fact that neither XP, or Ubuntu can see the optical drive seems to
> > indicate a BIOS problem, or some setting that needs to be changed for the
> > optical drive in the BIOS. It's worth a good look through the various
> > menu items in your BIOS.
> >

> > Also have a look in the /dev directory/folder. Depending on what your
> > optical drive is capable of, you may see symlinks for cdrom, cdrw, dvd,
> > and dvdrw. In my case these symlinks are all pointing to hda, which is
> > the block device for the optical drive. This is with Kubuntu Gutsy Gibbon
> > 7.10.

> > Nigel.
> Hi Nigel,
> many thanks for your efforts, have attached output of dmesg,
> can't see any reference to scd at all, appears "No block devices found"
> The bios doesn't seem to have any settings to access cdrom drive settings.
> Bios
> Main  - System time
>         System date
> Quiet Boot - (enabled)
> Network Boot - (enabled)
> Advanced  Legacy USB support - (enabled)
>           Modem  (enabled)
>           SATA ControllerMode Option  - (Compatability)
>                                          Other option AHCI.
>  Needs to be set to "Compatability" to "See" the Hard Drive to install,
> have tried both options
> after install, same result.
> Device folder
> /dev/sda
> /dev/sda1
> /dev/sda2
> /dev/sdb
> /dev/sdb1
> squareyes at here:/media$ ls
> cdrom  cdrom0
> squareyes at here:/media$ mount /cdrom
> mount: special device /dev/scd0 does not exist (understandable)
> Weather here is warming up, your welcome to move here (South Australia)
> for a couple of weeks if you would really care to have this machine in
> front of you. No white Christmases here, 30° C here today and it's
> looking like we will have a very hot summer :-)
> Again many thanks
> take care
> Winton

Hi Winton.

Oh dear. Oh dear oh dear. I've been reading through posts on the Lenovo forum 
for the 3000 this afternoon, and there are a bunch of folks unhappy with the 
optical drives that come on the 3000. Matsushita is one make that stands out.

From other hits I got on Google, including one of yours from earlier in the 
year, I saw the following stuff, and did you try appending the kernel line in 
Grub with, combined_mode=libata ?

Anyway. One guy said the only distros he installed, where the optical drive 
worked, were Slackware, and Foresight. Then he said that the solution he 
found was to use LiLo as the bootloader instead of Grub, and that was with 
Mandriva 2008.1 Free.

It's not the first time that I've seen using LiLo instead of Grub, has 
resolved some problems that Grub seems unable to deal with.

Someone else had problems with the drive after installing iTunes. But that was 
something that seemed to be specific to Windows Vista, and there was a fix 

And yet another suggestion was to append the kernel line in Grub, with:
That may well be worth a try. When you get the grub menu, press E, then down 
arrow to kernel, and press E again. If the "quiet splash" is at the end of 
the kernel line, use backspace to remove it, and add the "all-generic-ide" 
bit (without the quotes), to the end of the kernel line after leaving one 
space. Then press Enter, followed by pressing the B key.

Removing the "quiet splash" bit will enable you to see a bunch of text when 
you boot, which is pretty much as you see in dmesg, but sometimes there is 
stuff which isn't saved in dmesg. It does scroll past pretty fast.

The guy above who suggested LiLo as a fix, said that before he installed 
Fedora 9 (his first install of Linux on the machine, and dual booting with 
XP), the dvd rom drive was working ok with XP. It was only after installing 
Fedora 9, that the drive no longer worked, either with XP, or Fedora 9.

Did the dvdrom drive work for you, when you only had XP on the machine?

I can't make the trip to Oz, but it sounds nice. Barbie on the beach on 
Christmas day sounds quite surreal from where I'm living in Northern France.

I'll try to find out how to install LiLo instead of Grub. Synaptic shows LiLo 
as available to install on my Kubuntu GG install, but having never replaced a 
bootloader with a different one, I don't want to mess up anything with any of 
my currently installed distros. I have a bunch of freespace on another 
harddrive, and am 93% done on downloading the iso for Intrepid Ibex (on 
dialup). I don't remember there being an option to use LiLo on my GG, and HH 
installs, but we'll see. If not I'll install Grub as bootloader for Intrepid 
8.10, then play around with replacing Grub with LiLo, which should be 
interesting to say the least.

All the best mate.


More information about the ubuntu-users mailing list